Diablo® III

FPS drop in Act 3

I want to know if anybody else is experiencing issues like mine.

Okay so first off let me explain what happens

Ever since the last maintenance of 2012 (somewhere between 3rd -4th week of Dec), I have been experience FPS drop in Act 3, specifically in Rakkis Crossing and Arreat Crater 2. It usually happens during large mobs, where my FPS would drop down to single digits.

Now I was extremely worried about this since my PC can handle more intensive games than D3. So i tried playing the game at the lowest setting possible, and i still get this crazy FPS drop. Does anyone else have these problems? it's kinda irritating to play with the spikes.

However, none of the FPS drops happen in other areas even if the mobs are bigger ex. halls of agony 2

FYI high temp is ruled out since I've monitored it and nothing is hot.
FYI connection is stable at green

PC specs
Desktop PC (built my own)
Processor: Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz (4 CPUs), ~3.1GHz
MOBO: ASUS P8Z77-M PRO
Video Card: ATI Radeon HD 5850 Series
Memory: 8192MB RAM
OS: Windows 7 Home Premium 64-bit

Temperature is controlled as i have multiple fans and a good Case

TL DR; LAAAAAAAGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGG

PS since the technical forum is useless. I'll give the person who helps me fix this 2M gold (i don't have a lot)
Edited by CaptNuts#1334 on 1/9/2013 6:27 AM PST
Reply Quote
Very common. I'm not gonna put all my specs up, as I just woke up. But know that you're not alone, most people see a big FPS drop in Act III, ESPECIALLY on Rakkis Crossing. It's pretty weird to think that this game, which is very minimal in it's memory/video requirements, can even have enough going on to cause an FPS drop.

It's not you. It's the programming. I'm sure they'll fix it in time, or with an EXP pack.
Reply Quote
Very common. I'm not gonna put all my specs up, as I just woke up. But know that you're not alone, most people see a big FPS drop in Act III, ESPECIALLY on Rakkis Crossing. It's pretty weird to think that this game, which is very minimal in it's memory/video requirements, can even have enough going on to cause an FPS drop.

It's not you. It's the programming. I'm sure they'll fix it in time, or with an EXP pack.


but... i never got this before
Boooooooooo
damn you programming!
Reply Quote
do a search for "HDD major stuttering problem solved" - it's in the technical support forum. It involves installing the MPQs folder on a USB 2.0-3.0 flash drive and junctioning it via CMD prompt - also, reduce sound channels to 64 or 32.
Edited by Elixirboy#1593 on 1/9/2013 7:04 AM PST
Reply Quote
I am glad to see this post as you are not alone. I too have noticed significant problems in Rakkis Crossing, and a few areas in the Core of the Arreat where my FPS dives to like 5-10 FPS. Everywhere else it usually is flawless. I actually turned my graphics all the way down (usually maxed out with AA on) and even cut some things off and it still lagged the same amount.

Computer Specs (Built on my own):

Processor: Core i5 3570K OC@4.2Ghz
MOBO: Gigabyte GA-Z77X-UD3H
Memory: 8GB Ram
Video Card: Nvidia Geforce GTX 560TI
OS: Win 7
Hard Drive: Samsung 840 series SSD

I too monitored the load and the temperatures were way low and the processor was only at 20-30% load.
Edited by Potzors#1550 on 1/9/2013 7:18 AM PST
Reply Quote
01/09/2013 06:58 AMPosted by Elixirboy
do a search for "HDD major stuttering problem solved" - it's in the technical support forum. It involves installing the MPQs folder on a USB 2.0-3.0 flash drive and junctioning it via CMD prompt - also, reduce sound channels to 64 or 32.


I'd give you props for helping me solve it, but my Diablo 3 is running on a Corsair Force 3 SSD ATA... however i will give it a try if it does work i will msg you

@potzors: thanks for the feedback... this is driving me crazy already. I mean the FPS spike lasts like 5 sec max, but it's annoying since the only lag i expect is from the net.
Reply Quote
580 gtx here and a fast ssd yet I'm playing turn based combat like the OP. BF3 on ultra settings at 1900*1200 no problems though.
Reply Quote
I have no issues but hope you the best
Reply Quote
i had the same experience with the last patch, except in act 2 instead. i keep getting major slow downs in the oasis

i am using the rmpb base model with the gt650m. previous to this patch, i was able to get 50-60fps consistently throughout the entire game. note that i am playing bootcamp with windows 7
Edited by perfectblade#1433 on 1/9/2013 9:47 AM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]