Diablo® III

Rakkis crossing 1fps, on 670GTX

I run far cry 3, bf3 all on ultra without problems...
Diablo 3 runs perfect untill i go anywhere NEAR that long bridge.. I dont get 10 fps, not 5, but 1.
It is impossible to play there..

5 Mill to who ever helps me.
Reply Quote
lower background fps slider bar in options?
Reply Quote
Its already on the lowest infact its turned off i think.
Reply Quote
i know how you feel man. i have an HD 6990 and the game runs perfectly everywhere else but there.
Reply Quote
When was the last time you updated your video drivers?

I'm running an old system with old GTX 275. I occasionally have FPS issues when I first load up the game (seems to be that the first time I encounter enemies it slows down). After that, I get minor slow downs randomly and a slight consistent slow-down on Rakkis Crossing but I've never dropped below 30 FPS there. My friend with a fast computer gets minor slow downs there too but nothing like 1 FPS.
Reply Quote
agree. it chugs only on rakkis crossing on my GTX590 too.

^ also FYI background fps is the frame rate for when the game is in the background (ie. is the non focus window or you've alt-tabbed to the desktop) so shoul dhave no bearing on in game framerate.

i am getting better performance (though yet to check on that particular zone) by disabling vsync in game, and enabling it it via the nVidia control panel. perhaps there are other options that would be better controlled in this fashion?
Reply Quote
01/10/2013 08:46 PMPosted by TheSLAP
When was the last time you updated your video drivers?


i am always up to date with my drivers. i even double checked to see if there was another update. but no. i may have to do a rollback and see if it's just that driver that is the issue.
Reply Quote
agree. it chugs only on rakkis crossing on my GTX590 too.

^ also FYI background fps is the frame rate for when the game is in the background (ie. is the non focus window or you've alt-tabbed to the desktop) so shoul dhave no bearing on in game framerate.

i am getting better performance (though yet to check on that particular zone) by disabling vsync in game, and enabling it it via the nVidia control panel. perhaps there are other options that would be better controlled in this fashion?


You might be onto something because i HAVE to run in game vsync or else its choppy.. Very choppy. Ill run it through nvida panel and turn it off in game see if its better.
Reply Quote
Turn your sound to 32 bit that should help helped me.
Reply Quote
Check NVIDIA settings, Diablo may not be utilizing your video card and trying to run off of CPU integrated graghics.
Reply Quote
Delete System 32!
Reply Quote
i've got the GTX680M and every game runs on ultra high, 1920x1080p.

Same problem as the OP but only during heated battles on Rakkis. I think this is a similar defect to the Maghda fight where it dropped to 10 fps, but Blizz fixed it in the last patch.
Reply Quote
Might be more to do with hard drive load times than your graphics card.
Diablo tends to not load textures until you see a monster for the first time, and there's a crap ton of monsters on that bridge.
Reply Quote
Might be more to do with hard drive load times than your graphics card.
Diablo tends to not load textures until you see a monster for the first time, and there's a crap ton of monsters on that bridge.


though, i have mine running off ssd and still see a performance drop only in that area.
it's a curious one for sure.
Reply Quote
Turn your sound quality down, see if that helps.
Otherwise maybe your CPU is weak but it probably isn't if you're running everything else fine.
Reply Quote

i am getting better performance (though yet to check on that particular zone) by disabling vsync in game, and enabling it it via the nVidia control panel. perhaps there are other options that would be better controlled in this fashion?


You might be onto something because i HAVE to run in game vsync or else its choppy.. Very choppy. Ill run it through nvida panel and turn it off in game see if its better.


if i recall after you add the exe to the control panel and change its settings you need to restart the game for these to take effect.
Reply Quote
Might be more to do with hard drive load times than your graphics card.
Diablo tends to not load textures until you see a monster for the first time, and there's a crap ton of monsters on that bridge.


Crossfire 2x HD 6590
OCZ Vertex 4 SSD
Great internet connection

Still get horrible lag in Rakkis crossing.
Reply Quote
7970, Rakkis crossing still owns it.

Back in 1.02, 1.03 with my old 4870 1GB, I did not have any problem....
Reply Quote
I am running the same video card piggyback to a intel 4000. for 4 gigs of ram i can do rakkis bridge with over 20fps in full settings in full 3d at 1900/1080. it must be the driver or your configuration. cant say for sure but know that is not right
Reply Quote
I farm there too with a 7690m and I get 60 fps.
Edited by TheFunGun21#1392 on 1/10/2013 9:08 PM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]