Diablo® III

Must be my internet connection.......

Posts: 8,057
View profile
Figured I'd use a faster internet service to combat this terrible lag problem, still lagging and still rubberbanding....
http://img705.imageshack.us/img705/4292/wifiint.jpg

Computer is running at 4+ GHz, 16gig ram, ssd, blah blah blah, PC is good, internet is good, whats the problem here?

Come at me fan boys, lets here some more excuses....
Reply Quote
download more ram
Reply Quote
The servers took a dump for me after Christmas. My guess is a sudden influx of people on holidays/people getting the game for Christmas.

It is better now, but there was a week or so there where I couldn't even get through an alk run without terrible latency or an outright disconnect.
Reply Quote
Posts: 8,057
View profile
01/06/2013 05:45 AMPosted by starcraft
download more ram


Where can I do that at?
Reply Quote
Posts: 8,057
View profile
thx for the redirect, like to hear an answer for this one.
Reply Quote
Posts: 8,057
View profile
No reason for rubberbanding or random disconnects?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]