Diablo® III

Error opening Diablo 3 after hitting "Play"

90 Blood Elf Warlock
8535
I use a Macbook Pro with a 2.3 GHz Intel Core i5 Processor, with 4 GB 133 MHz DDR3 Memory. Not sure if that's relevant to my current issue.

I haven't played Diablo for quite some time now, but recently i've been in the mood to continue playing a bit. I finished downloading the patch the my launcher prompted me to download. Upon completing the patch download, while it telling me "Game is up to date", i finally decided to hit "Play" on my launcher.
After hitting Play on the launcher, the launcher would disappear like usual and display the Diablo symbol in the center of my screen like usual. However, once all of that disappears, I get a big yellow triangular "!" symbol on my dock, and it says "Blizzard Error" furthermore brings up a screen telling me to explain my problem and says "application encountered an unexpected error", but of course, i never get any feedback after explaining it which is why i am here now.

How can I solve my problem? Please and thank you!
Reply Quote
MVP - Technical Support
90 Draenei Mage
6490
Have you tried going to Mac HD -> Users -> Shared and deleting both the Battle.net and Blizzard folders ?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]