Diablo® III

Error during bid for a sword: lost 4 million

Today I tried to buy a rare sword. I was AFK for several minutes and I'm not sure wether the auction of the sword was already expired or not, when I tried to make my bid.
After my bid of over 4 million gold an error message popped up (I'm not sure I think it was error #33) and my gold was gone without having received the sword.
A second message said that the access for the sword was overloaded.
Now when I'm looking for the sword in the search section of the auction house then I can find an empty square and alongside the expired state.

Search settings: Monk level 60, onehanded, sword, dexterity, vitality, attack speed and 1 socket.

Please help me, I want my 4 million gold back!

Thank you for your answers in advance.
Reply Quote
I won an auction and I never got the item. Blue responded to my post and said to wait 72 and then submit a claim. I got my item after 5 hours. Tons of people are having issues, I don't think items/gold are gone, things are just really delayed.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)
Submit Cancel