Diablo® III

Where is the answer or feedback?!?!?!

Many people are experiencing a huge "lag" or fps slow on Korsikk and Rakkis since patch 1.05, PEOPLE TRIED EVERYTHING TO SOLVE IT, changed gpu, tried another network connection, and nothing worked!

And all that this "support" did was ask for Dxdiag and MSInfo, we are sure that its a bug from the game because there are experts in hardware and software that are experiencing that problem. There are MANY TOPICS that the people are raging about the treatment of this "support" because they arent solving that same problem!

Common, WHERE IS THIS SUPPORT!

Stop asking for Dxdiag, MSInfo and FIX THAT BUG!

Related topic that i've found (im sure if i do another search ill found new ones):

http://us.battle.net/d3/en/forum/topic/7392969600?page=1#4

http://us.battle.net/d3/en/forum/topic/7382118150?page=1#9

http://us.battle.net/d3/pt/forum/topic/7415604632?page=1#9

http://us.battle.net/d3/pt/forum/topic/7392969618#1

http://us.battle.net/d3/en/forum/topic/7592913225

http://us.battle.net/d3/en/forum/topic/7708951396
in that last one just pay attention to the ridiculous answer from Omrakos:

Ngarda,

With vsync enabled as your prefs file indicates it is, you shouldn't be seeing more than 60 fps and it ought to be stable provided your computer can maintain it. There will be spots in the game (Act 3 in particular) that can cause it to dip though and there really isn't anything you can do about that.

Continuing with the same problems topics:

http://us.battle.net/d3/en/forum/topic/7343944336
(note: that topic wanst answered from a blue and look when i was created! More than 6 months ago!!!!!!)

http://us.battle.net/d3/en/forum/topic/6413081967

Im waiting some aswer telling us WHEN IT WILL BE FIXED!
Reply Quote
you've broke the game GPU use is now INSANE I dunno what you did but you screwed something up I cant even play
Reply Quote
The problem is related to the sound! Dont know exactly what it is, but i've tried to down the sound quality 3 months ago and it didnt worked. But know it worked! The fps keeps going down below 10fps sometimes, but at least the screen dont freeze anymore when i'm playing alone... Weird!
Reply Quote
Have you run memtest? This sounds like a bad stick of ram to me.
Reply Quote
Posts: 39
The problem lies with blizzard's server's a lot of people are getting lag...there is a problem and they don't want to admit it.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]