Diablo® III

Updating Blizzard Launcher.... never ends ?

The update tools is broken or what ?
freeze around 60% for half an hour!
Reply Quote
It is frozen for me too. Launcher first got an error during update said I didn't have a connection then closed. After checking my connection as being good, Launched again and it sits at 60 percent. What is the deal, at least I know it isn't just my computer. Help!
Reply Quote
I deleted the "Battle.net" folder per the directions in the launcher support thread. When I restarted the launcher, it downloaded again and now I get the message everyone else is getting for video card not supported. I hit escape and game works. Good luck.
Reply Quote
Support Forum Agent
Posts: 33,999
Marvi

Try this:

1. Make sure that Windows is set to show hidden files.

Here's how to do that: http://windows.microsoft.com/en-US/windows-vista/Show-hidden-files

2. Navigate to the C:\ProgramData folder and delete the Battle.net folder.
3. Navigate to the Diablo III folder and delete the "Updates" folder.
4. Launch Diablo III.

Let me know what happens.
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Reply Quote
Switch the game to french but it's all good now thank you Dankorii
Reply Quote
Support Forum Agent
Posts: 33,999
Marvi

You're welcome, please feel free to post again if you have any other questions or problems.
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Reply Quote
Same issue, tried setting windows to show hidden files, didn't work. Still restarting the download after 100% and I don't know where to set my game to French :o
Reply Quote
same issue
Reply Quote
can't delete battle.net folder says its in use, cant seem to end the agent.exe process get access denied error, although i am administrator and have full permissions, any suggestions?
Reply Quote
ran a clean boot, was able to delete battle.net cache folder. everything seems to be working now
Reply Quote
Same. Stuck updating - old pc/card but it has worked since release until now honestly.
Reply Quote
Support Forum Agent
Posts: 33,999
Onyx

Delete the Battle.net folder again from the ProgramData folder, and then delete the Blizzard Entertainment folder from the same ProgramData folder. Try the launcher again and let me know what happens.

I don't know where to set my game to French :o


To change the language, you have to get to the login screen > click on Options > click on Account > select the language from the "Language Selection" drop down menu.
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Reply Quote
Deleting those two files does nothing to fix the update launcher from stalling.
Reply Quote
My install launcher reboots my computer and I did everything above as well as the other stuff recommended.
Reply Quote
Support Forum Agent
Posts: 33,999
SpawnKiller

Another program may be interfering. Try running a selective startup to get around this. Please be aware that running while in this mode can potentially disable any security programs you may have running.

Hold the Windows key on your keyboard and press the letter 'R'. In the Run field type "msconfig" and hit Enter.
In the General tab:

1. Choose Selective Startup
2. Disable (uncheck) Load startup items
3. Click OK and Reboot

To undo selective startup, just recheck Load startup items.
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Reply Quote
How about an update?

Is there a direct down load link for the installer update on the web site?
Reply Quote
any other fixes?
Reply Quote
Another program may be interfering. Try running a selective startup to get around this. Please be aware that running while in this mode can potentially disable any security programs you may have running.

Hold the Windows key on your keyboard and press the letter 'R'. In the Run field type "msconfig" and hit Enter.
In the General tab:

1. Choose Selective Startup
2. Disable (uncheck) Load startup items
3. Click OK and Reboot

To undo selective startup, just recheck Load startup items

Doesn't work

Its on your end, never had any issues until now
Reply Quote
Is there a direct download for the files to replace the ones deleted?
Reply Quote
we need a direct download link to replace the files after manual deleting them.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]