Diablo® III

constant update of Launcher

- Diablo III
Posts: 1,409
View profile
Just wanted to chime in on this conversation. I just bought an iMac on Sunday and I have no problems at all launching the game. However, using my old MacBook Pro it usually takes me around 4-6 attempts at launching the game before I can finally get in. The updating tool bar gets stuck at 75% every time with the only solution being to force quit the application. If you keep trying to launch the game eventually it goes straight to the Blizzard Launcher and you're able to click play and everything seems to work from there. I had even tried uninstalling D3 entierly from my macbook and using a fresh install but still ran into the same problem on the first launch of the game.

Pretty annoying.
Reply Quote
Support Forum Agent
Posts: 14,784
Thanks for the feedback about this, I'll do a bit of research on this.
Reply Quote
- Technical Support
Posts: 11,512
View profile
Just a quick update that I'm still looking into the issue while the folks up top look into it on their end. I haven't come up with any solutions other than the temporary workaround noted earlier in the thread, but since this is a rather pervasive problem for those that have it, I don't intend to give up until I can say it's fixed.

If anybody continues to have this problem (and exactly this problem only, please), post in this thread and make sure to give your system information (hardware, and software tab in System Profiler). Any data collected hopefully brings us closer to solving this enigma.

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Reply Quote
Support Forum Agent
Posts: 14,784
^^ This.
Reply Quote
MVP - Technical Support
Posts: 11,512
View profile
I am no longer experiencing this issue. It would appear that the folks responsible for the Launcher's back end have fixed whatever was causing this on Blizzard's end as nothing has changed on my end at all with regard to the apps or their builds.

So thank you to those responsible for resolving this. Here's hoping it never crops up again. :)
Edited by TheTias#1192 on 5/2/2013 7:23 AM PDT
Reply Quote
MVP - Technical Support
Posts: 11,512
View profile
This is a final confirmation post to let others know this issue is indeed fixed. I made sure to test this by backing up my Blizzard and Battle.net folders in /Users/Shared/ and deleting them so the game would create fresh new directories. Although every Launcher (for each game I have installed) asked for my password the first time and the Diablo III Launcher got stuck on Initializing for about 45 seconds before continuing, none of the Launcher apps are giving me the update cycle on each launch anymore.

So this issue should now be resolved.

Thank you again to Machkhan, S4d1k and all others involved. This is a tremendous annoyance now gone.
Reply Quote
Support Forum Agent
Posts: 14,784
Woot!
Reply Quote
I am no longer experiencing this issue. It would appear that the folks responsible for the Launcher's back end have fixed whatever was causing this on Blizzard's end as nothing has changed on my end at all with regard to the apps or their builds.

So thank you to those responsible for resolving this. Here's hoping it never crops up again. :)


Same here - game's been rock-solid for me too. Add my thanks to the Mac support team for fixing whatever they fixed!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]