Diablo® III

Question about Barb life steal...

Hi all.I was wondering if anyone with a WW Barb is experiencing what I have been.First my barb's relevant stats:

Paragon lvl 23
Crit chance 51%-49%(unbuffed)this goes to 61% with Wotb.
Crit damage 494%
LS-5.80
LOH-1747
48k life
163k damage(unbuffed)235k(Buffed)

Now my issue,I run mp8 act 3 normally with no problem's.One thing that i notice is that on the occasion I die(and yes I know it will happen) whether it is an elite pack or reg mob my character isnt stealing any life.I only have healing number's displayed.There is no green number's being displayed and my life just drop's as if I am standing in fire with no gear on.So then I thought it might be the affixe's that the elite pack's might have so i paused and wrote them down.What I found is that i can run across an elite pack with the same affixes that caused me to "Die" and I have no problem's.It just seem's like the LS and LOH fail sometime's.

Has anyone other than me experienced this before?

Any input is appreciated.Ty in advance.

E/* This also happen's with regular mob's also not just elite's.
Edited by Dedmnwlkn#1495 on 2/1/2013 11:08 AM PST
Reply Quote
The only reason I've ever noticed LS fail is on Health Link packs. Health Link combined with certain affixes, notably Molten and to a lesser extend Electrified, can drain your life faster than you can regenerate it (dependent on your AR).

I've read about the reasons for this, but rather than making a fool of myself trying to explain it (incorrectly) I'll let someone else do that.

However, you say this happens on regular mobs as well. And for that, I have no explanation.
Reply Quote
As far as I remember, Health Link life steal used to be broken. Will probably be fixed on the next patch.

Btw, if you're using Double Tornado build, you might have to consider getting more attack speed or going dual wield.
Reply Quote
Posts: 2,100
View profile
The health link affix interaction with LS is bugged. Health link splits the damage between all of the mobs in the pack (normally 3) but it does not return health for damage split to other mobs. For example, if you're just attacking one mob then you will only get 1/3rd of your normal LS healing. If you attack all 3 at once, you will only get as much as if you were just attacking one normal mob.

Been bugged like this forever and it still hasn't been fixed.
Reply Quote
The only reason I've ever noticed LS fail is on Health Link packs. Health Link combined with certain affixes, notably Molten and to a lesser extend Electrified, can drain your life faster than you can regenerate it (dependent on your AR).

I've read about the reasons for this, but rather than making a fool of myself trying to explain it (incorrectly) I'll let someone else do that.

However, you say this happens on regular mobs as well. And for that, I have no explanation.


As far as I remember, Health Link life steal used to be broken. Will probably be fixed on the next patch.

Btw, if you're using Double Tornado build, you might have to consider getting more attack speed or going dual wield.


The health link affix interaction with LS is bugged. Health link splits the damage between all of the mobs in the pack (normally 3) but it does not return health for damage split to other mobs. For example, if you're just attacking one mob then you will only get 1/3rd of your normal LS healing. If you attack all 3 at once, you will only get as much as if you were just attacking one normal mob.

Been bugged like this forever and it still hasn't been fixed.


Ty guys as I was not aware of this "Bug"...I noticed a little harder time killing these but normally I dont have a problem.

02/01/2013 11:20 AMPosted by Danny
Generally if that happens to me I notice rubberbanding and I attribute it to lag.


This is probably what is happening as i do notice for instance that when it just happened to me it appeared as if my character was out of the pack and then was back in and then my life was gone.None of these mob's had the health link affix.It happened 3 time's since this post and 2 out of the 3 it was like my character popped out of the mob and back in and one was a reg Mob.

Is there anyway to fix this??I have a pretty decent cpu and I-net connect.
Reply Quote
The WW build is very sensitive to lag and gets worse with lower EHP. Your EHP and leech seem fine, so I am guessing you are just getting a lot of lag when you play. Lag is a reason to turn on all numbers -- not just heals. You can see when you are hitting stuff with numbers on, as they will suddenly stop during lag storms.

To fix your problem, I recommend doing this --

1) Hit "V" to show all monster health bars. If the bars aren't going down when you think they should, it's lag. This may be less obnoxious than 2).
2) Turn on all damage numbers or at least white hits or criticals. It will make lag easier to detect.
3) Incorporate rend into your WW build. Substitute Rend:Blood Lust for warcry:Impunity. You may also be able to drop bloodthirst for superstition when you do this.

Rend:blood lust is a great skill for keeping you alive in bouts of lag. When I see lag, I start mashing rend to tag as many monsters as I can during the intermittent communication. Even if you think you are clear of the pack, you should do this. The server thinks you are somewhere else, surrounded. You tell the server to rend, and if you are surrounded on the server side, you will hit things.

What you do now most likely is cast sprint and run away from the lag. You think you can keep running, but actually, you are stuck in the pack. You collide into the monsters and cannot move. Even if you WW, it doesn't help. The server sees you clicking on a strange location -- it is too far away or in some void, so it doesn't let you move. You stand still channeling WW or sprinting in place.

Typically with rend up on a few targets, you will be unkillable. Rend persists for 5 seconds and it doesn't matter if you are lagging or not -- the heals will still come in. With rend in your build, you will spend less time punching your monitor when your ISP craps out.

This does not work as well for a dual wield barb because rend is not as good, but for 2H WW, it works great (one reason to not be dual wield/WW)!

There is a separate issue with dual wield WW where leech seems to stop working, or seems sluggish. This can be lag also, but sometimes it has to do with the weapon speed being referenced at that moment in time. If you get the slow weapon, your ticks go down and your LoH and lifesteal both plummet until the next weapon is swung. You will see fluctuations in heals coming in - against difficult elites at high MP, you may be just barely winning at the start, then the slow weapon turns on, your effective dps reduces to ~70-80%, and your health drains out, and you die. If your weapon speeds match (or you have just one weapon) you will not experience this phenomenon.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]