Diablo® III

High latency in ACT 3

I am in Asia server, and I understand I should post in Asia server forum, but there's nobody responding in that forum.

The problem is that when you enter ACT3, you have super high latency, normally more than 2000ms. That's completely unplayable. The only "fix" to that is to go somewhere out of town and have check point, so you can save your progress out of town. Exit the game and resume, and you'll resume at the last check point. Then don't go back to town immediately. Go to other place first, and then go back to town. After that the latency problem is gone. It seems like if you don't enter the game in town, the problem does not happen.

The problem has been there since 1.0.5. Almost every single person in Asia server has that problem. Some even have the same problem in ACT1. The "fix" does not work in multiplayer game, because even after saving at check point, you still resume at town in multiplayer game. That gives a lot of trouble to multiplayer inferno gate games. If someone gets a lag, there's no way to fix it and he can only drop from the game.

This is a problem that has been there for couple of months. Please fix it as soon as possible.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]