Diablo® III

Video card issue

90 Human Warlock
6680
So I have a relatively new, GOOD macbook pro. I normally play WOW on it, but tonight I decided to play D3.

I downloaded a patch (nothing crazy out of the norm, I haven't played D3 in a while) and when I clicked play, it said D3 didn't support my Video Card.

WTF?

So I rebooted my mac, and still same message.

D3 used to run perfectly fine, on my beast 17 inch macbook pro. As does wow.

What happened?
Reply Quote
Support Forum Agent
Can you provide the exact error message, and your system specs?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)
Reply Quote
90 Human Warlock
6680
Thanks for the response!

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro6,1
Processor Name: Intel Core i5
Processor Speed: 2.53 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 4 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: MBP61.0057.B0F
SMC Version (system): 1.57f17
Hardware UUID: 32198702-FA5C-5BAB-9F91-09286A109ADC
Sudden Motion Sensor:
State: Enabled

Graphics:

Intel HD Graphics:

Chipset Model: Intel HD Graphics
Type: GPU
Bus: Built-In
VRAM (Total): 288 MB
Vendor: Intel (0x8086)
Device ID: 0x0046
Revision ID: 0x0018
gMux Version: 1.9.22
Displays:
Color LCD:
Display Type: LCD
Resolution: 1920 x 1200
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

Chipset Model: NVIDIA GeForce GT 330M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0a29
Revision ID: 0x00a2
ROM Revision: 3560
gMux Version: 1.9.22

System Software Overview:

System Version: OS X 10.8.2 (12C60)
Kernel Version: Darwin 12.2.0
Boot Volume: Box
Boot Mode: Normal
Secure Virtual Memory: Enabled
Time since boot: 13:51
Reply Quote
Support Forum Agent
Thanks. Can you make sure you have graphics switching disabled? It might be picking up the Intel HD chipset , which isn't supported.
Reply Quote
I ran into this problem too. It seems the graphics card check happens before the graphics card switching does. The end result is an erroneous message that the 330M is not supported. Forcing the computer to use the 330M prior to launching D3 does fix the problem.
Reply Quote
Support Forum Agent
Thanks for the report on this. I will escalate this to our team for review.

Are you able to provide a screenshot for the error?
Edited by Machkhan on 2/13/2013 10:33 AM PST
Reply Quote
Sure.

http://img29.imageshack.us/img29/3071/screenshot20130213at359.png
Reply Quote
Support Forum Agent
Thanks. I've send all these data up for review :)
Reply Quote
Support Forum Agent
So, few more questions.

  • When this issue happens, can you press OK and the game? Or does it prevent you from playing?
  • Can you post your device ID as well?
    You can find it in the system report > Device ID
Edited by Machkhan on 2/13/2013 1:45 PM PST
Reply Quote
Pressing OK quits D3 and opens a web browser to the unsupported video card list.

Device ID is the same as the OP's (0x0a29).

Additional note: the error doesn't appear all the time; sometimes D3 starts normally.
Reply Quote
Support Forum Agent
Thanks. We're reproduced this error on our end. We should be able to handle it from here. Are you able to play normally when you ensure that graphics switching is disabled?
Reply Quote
This is happening to me too, I have the same MacBookPro with a NVIDIA GeForce GT 330M, I could play fine before the latest patch, and I don't want to keep the 330M always on when isn't necessary.
Reply Quote
02/14/2013 03:59 PMPosted by Machkhan
Thanks. We're reproduced this error on our end. We should be able to handle it from here. Are you able to play normally when you ensure that graphics switching is disabled?


Yes, D3 runs fine once it actually launches.
Reply Quote
So, whenever I try launching the game via the "Diablo III" or "Diablo III Launcher" app, I sometimes get the same error message:
http://i.imgur.com/J3bbsEy.png

It's either one or the other. But, when I launch the game from the other app, it launches fine. I didn't have this problem when I last played, which was around June last year. This is the MacBook Pro I have:
http://www.everymac.com/systems/apple/macbook_pro/specs/macbook-pro-core-i7-2.66-aluminum-15-mid-2010-unibody-specs.html
Edited by celebi23#1841 on 2/21/2013 1:07 AM PST
Reply Quote
Support Forum Agent
Thanks. The issue is still being worked on, but I will update when I know more.
Reply Quote
Has there been any update to this since 2.0?
Since the patch, I get the error BLZBNTBNA00000131 (video card not supported by D3) regularly on startup and while it no longer keeps me from playing (thanks for that, I do appreciate the "Play Anyway" button), it does make me wonder if I've got something configured wrong.
MacBookPro 6,2 Core i7
OSX 10.8.5
NVIDIA GeForce GT 330M 512MB (0x0a29), switching disbaled
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]