Diablo® III

Patching Error can't go past Initializing

Hi,

A couple of days ago I tried to log in and play Diablo III. However, the launcher got stuck in Initializing... Then I got the message "Failed to download required file. Check your internet connection". My internet connection is working perfectly. I tried changing it to run the program as Administrator, nothing. Turned off my firewall and my anti-virus, nothing. Still gets stuck and getting the same message. I ultimately uninstalled the program, as many treads in the forum said to do, but when I tried to install it again, it got stuck on Initializing and 0.0%, and afterwards I get the same message. I've read many treads saying to delete the Update folder and the Battle.net folder, as well as the .tfil and .mfil files, nothing.

Does anybody know how to fix this problem?

Help Blizzard!

P.S. I got the same issue while trying to install SC2.

I also tried to install it in another computer, same issue.
Edited by GLKilowog#1641 on 2/14/2013 10:08 AM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]