Diablo® III

Hanging up at launcher

Posts: 173
Hey there, been gone for a few days. When trying to update to the new patch it hangs up on the launcher around 70%

Solutions iv tried-

Ctl alt delete agent.exe

Renamed agent file to agent.temp

Tried installer again

Did not fix

Anymore solutions other then that? (all iv found on google in a quick search)

I'm going to try safemode now after this post to see if that works.

US

Not working in safe mode, tried above steps also and nothing happend.

Pretty stuck, some info on my side

US server (In US as well)
downloaded the game via website
computer hardware is fine
Edited by fireboltz#1324 on 2/15/2013 9:30 AM PST
Reply Quote
bump
Reply Quote
hi fireboltz

update adobe flash and it works :D
Reply Quote
Posts: 173
Using google chrome it auto updates...

http://i.imgur.com/pgXSnDQ.jpg

Should 3 of those be running? (The screenshot was in safemode)

Back to normal mode, let it run awhile and now i have 9 differnt agent.exe's running...
Edited by fireboltz#1324 on 2/15/2013 10:04 AM PST
Reply Quote
Posts: 173
up
Reply Quote
Support Forum Agent
Posts: 42,814
fireboltz,

Having multiple Agent's running like that means Agent is not responding properly when the launcher checks to see if it's already running, so it starts another.

Kill any running Agent.exes in the task manager, then:

First, if you're using an antivirus program, try temporarily disabling it until the game is running.

Could you try what's described in the following two articles please?

https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS

https://us.battle.net/support/en/article/deleting-battlenet-tools-folder-pc?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS
Reply Quote
Posts: 173
This has been done.

Disabled advast for 1 hour, turned off windows firewall, followed both those steps.

http://i.imgur.com/DqXyVCW.jpg

^ What happend in about 2 seconds

This came out of logs

2013/02/15 17:35:42.008 - Blizzard Setup v1272 at 'C:\Program Files (x86)\Diablo III\Diablo III Launcher.exe' for diablo3_enus enUS reporting for duty!
2013/02/15 17:35:42.008 - Setup Complete!
2013/02/15 17:35:42.008 - Running as Admin.
2013/02/15 17:35:42.008 - Bootstrapper Stage: CHECK_PERMISSIONS
2013/02/15 17:35:42.010 - Bootstrapper Stage: CHECK_RUNNING_INSTANCE
2013/02/15 17:35:42.012 - Bootstrapper Stage: CHECK_ELEVATION
2013/02/15 17:35:42.012 - Bootstrapper Stage: UPDATE_BOOTSTRAPPER
2013/02/15 17:35:42.012 - Bootstrapper Stage: EXTRACT_AGENT
2013/02/15 17:35:42.013 - Agent needs to update. Extracting Agent.
2013/02/15 17:35:42.432 - Bootstrapper Stage: START_AGENT
2013/02/15 17:35:42.433 - Bootstrapper Stage: UPDATE_AGENT
2013/02/15 17:38:39.723 - Bootstrap::run exited.
2013/02/15 17:38:39.786 - Closing logs.
Edited by fireboltz#1324 on 2/15/2013 2:46 PM PST
Reply Quote
Support Forum Agent
Posts: 42,814
fireboltz,

Avast is still running according to your Task Manager in that screenshot. Make sure it's not running. The best way is to actually uninstall it but ONLY if you know it can be reinstalled later. Disabling it as you did should have been enough but I've seen where it wasn't.
Edited by Omrakos on 2/15/2013 2:51 PM PST
Reply Quote
Posts: 173
Alright, look at the screenshot again. If you go down the the bottom right and look at the orange thing next to the M Icon, thats advast. It has a big X on it.

That means its disabled and not doing anything.

http://i.imgur.com/upcSKvL.jpg
Edited by fireboltz#1324 on 2/15/2013 2:51 PM PST
Reply Quote
Support Forum Agent
Posts: 42,814
fireboltz,

The launcher hanging at the 70% mark is indicative of it not being allowed to write out changes to files. This is typically a permissions issue either from Windows' User Account settings or an antivirus app.

If you'd rather not uninstall Avast, could you try creating a new Windows User account, add it to the administrator group, then log off Windows and back on with the new user account and try the game?

https://us.battle.net/support/en/article/creating-a-new-administrator-account-pc?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS
Reply Quote
Posts: 173
Advast is gone

Here it is

http://i.imgur.com/eLybBod.jpg

Now what

Also I'm pretty decent with computers if you want to try some more elegant stuff.
Edited by fireboltz#1324 on 2/15/2013 3:04 PM PST
Reply Quote
Posts: 173
Got this out of the logs via d3 folder
Might help

#-----------------------------------------------------------
# System started at 2012-11-03 17:57:46.4350
# system: JAREN-PC
#-----------------------------------------------------------
17:57:46.4394 Failed to write file 'Appearance\a1dun_Leor_Jail_N_01.app' to disk.
18:02:51.3191 Failed to write file 'Textures\a1dun_Leor_NSW_01_scn_autoLM.tex' to disk.
18:39:48.1330 Failed to write file 'Textures\a1dun_Leor_NS_01_Executioner_scn_autoLM.tex' to disk.
18:41:59.2882 Failed to write file 'Textures\a1dun_Leor_W_Exit_Boss_01_scn_autoLM.tex' to disk.
19:10:54.5449 Failed to write file 'Appearance\a3dun_Crater_S_Exit_02_W01_N01.app' to disk.
19:11:02.0450 Failed to write file 'Appearance\a3dun_Crater_S_Exit_02_E01_N01.app' to disk.
19:11:03.6548 Failed to write file 'Textures\a3dun_crater_st_wall_A_01.tex' to disk.
19:11:32.3238 Failed to write file 'Textures\a3dun_Crater_S_Exit_02_E01_N01_scn_autoLM.tex' to disk.
19:12:08.5305 Failed to write file 'Textures\a3dun_Crater_ST_Entrance_01_E01_N01_scn_autoLM.tex' to disk.
19:24:00.5224 Failed to write file 'Appearance\a3dun_Crater_NW_02_W01_N01.app' to disk.
19:28:25.5786 Failed to write file 'Textures\a3dun_Crater_ST_Entrance_02_W01_S01_scn_autoLM.tex' to disk.
19:28:48.7297 Failed to write file 'Textures\a3dun_Crater_ST_Entrance_02_E01_S01_scn_autoLM.tex' to disk.
19:37:40.3805 Failed to write file 'Textures\a3Dun_Crater_S_exit_03_E01_N01_scn_autoLM.tex' to disk.
19:37:44.1930 Failed to write file 'Textures\a3Dun_Crater_S_exit_03_W01_N01_scn_autoLM.tex' to disk.
22:12:46.8365 Failed to write file 'Appearance\a3dun_Crater_NSW_02_W01_N01.app' to disk.
23:15:39.3062 Failed to write file 'Appearance\a3dun_Crater_NSW_01_W01_N01.app' to disk.
23:57:14.2819 Failed to write file 'Textures\a3dun_Crater_E_Dead_End_01_E01_N01_scn_autoLM.tex' to disk.
00:03:07.8644 Failed to write file 'Textures\a3dun_Crater_S_Dead_End_01_E01_S01_scn_autoLM.tex' to disk.
00:44:56.0992 Failed to write file 'Textures\a3dun_Crater_NEW_01_W01_N01_scn_autoLM.tex' to disk.
Reply Quote
Support Forum Agent
Posts: 42,814
fireboltz,

Can you try with the new user account I mentioned above?
Reply Quote
Posts: 173
yea sure, give me a moment.
Reply Quote
Support Forum Agent
Posts: 42,814
fireboltz,

"System started at 2012-11-03 17:57:46.4350"

Is the date set wrong for a reason or is this an old log file?
Reply Quote
Posts: 173
Only log file on there. That was the first time i tired installing.

Also, switching user accounts is has worked for whatever reason.

Its already ready to play and fully updated.

Will switch back to my orginal account and play.

Thanks for the professional and quick response times.

cya gents/ladies
Reply Quote
Posts: 173
Alright, I was almost out of the clear.

Swapped back to the other account (mine) and it got stuck at the launcher again.

Which files do i need to copy over?
Reply Quote
Support Forum Agent
Posts: 42,814
fireboltz,

I'm afraid I wouldn't know nor do I think it's a matter of copying files over anywhere. It's a Windows User Account issue in that the original account for whatever reason is being denied the ability to write out the file changes. In some cases, I've seen this method of creating and using a new user account work and the original account work as well afterwards, in others, it won't, such as you're seeing.

Working with User Accounts isn't something we're prepared to do though. It's something you'd want to get help from Microsoft for unfortunately.

You might try booting up in selective startup mode with the original account once in case there's a program it's using at bootup interfering with permissions or security. Safe mode as you've already tried should have had the same effect though.

http://us.blizzard.com/support/article/backgroundapps
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]