Diablo® III

Random Network Disconnection After 1.07 Patch

the level 60 hc char I lost was ww through some elites on full health when it happened
Reply Quote
Also getting DCed from server. It is a WW/Sprint problem from what I'm noticing because i switched back and forth between HOTA and WW and i only get dced on the WW spec. yes it is really annoying to be key farming, get 5 stacks, kill the warden, key drops, disconnect mid WW. got to love the bugs that make the game unplayable.
Reply Quote
What makes me most angry is that nobody cares to respond. Most people complain losing a 5stack nv, I lost 25.000.000 worth of equip on a hc char along with 35 hours game time.

This is obviously connected to some WW combo and not even one blue recognizes the problem with a post.

Sad customer support :/
Reply Quote
sorry, LETS DO ALL THE THINGS YOU WANNA DO. =P
Reply Quote
same problem here; after 1.07 patch. very annoying.
Reply Quote
76 Draenei Paladin
560
Posts: 4
This seems to happen when I enter a new area, someone joins my game, I join someone else's game, or I create my own game. I get the '...Client disconnected from server..' more often than the 316704 and 3007 errors. Restarting my computer and running Diablo 3 as admin don't seem to work. I allowed all the traffic on the ports that Diablo3 uses, still no luck. It doesn't matter what character I use either. All this after the 1.07 patch.

It really sucks when I get up on my day off and get excited to play Diablo 3, only to be presented with this crap.
Reply Quote
I have been getting the same sort of issue, was getting since 3 patches ago random kick out of game back to char screen, now since last patch I get kicked from game back to char screen then immediate kick right out of game to log on screen. nothing new on PC so don't start blaming that !@#$ was fine before these patches so please fix this crap getting sick of it.
Reply Quote
76 Draenei Paladin
560
Posts: 4
Been facing this problem several times an hour now. Ran Malwarebyte's and Spybot to clean my system, still disconnecting randomly. Joined General Chat (based on other things I have read), still no luck. Completely disabled all my firewalls, still getting kicked. Went to run Uber bosses and stepped into the portal, disconnected. Lost my Infernal Machine and portal was gone when I got back into my game.

what's up with this? I didn't buy this game so that I could barely play it...

//EDIT// Deleted Cache folder and let the D3 Client rebuild it, still getting disconnected.
Edited by WtchKng#1914 on 3/16/2013 2:13 AM PDT
Reply Quote
What makes me most angry is that nobody cares to respond. Most people complain losing a 5stack nv, I lost 25.000.000 worth of equip on a hc char along with 35 hours game time.

This is obviously connected to some WW combo and not even one blue recognizes the problem with a post.

Sad customer support :/


Yupp I lost a para 13 barb to this as well, that has very good gear for HC standards, probably 200 mil worth of HC.

Bump for Blizz response, I am considering quitting this game because I literally cannot play it due to so many disconnects.
Reply Quote
76 Draenei Paladin
560
Posts: 4
Bump.
Reply Quote
Bump
Reply Quote
Having the same issue net is fine ran a trace to blizz servers and no hangups. My client was fine till today when i tried to use it. I had 0 issues yesterday trying to play. A friend on the same connection is playing just fine both using wireless. Or when i get in a game i have no Waypoint picture and cant use it. ive done all the FAQ things even reinstalled still no good.
Reply Quote
I too am having the same issue, I had it before the recent patch but it seems to be happening far more frequently since the patch. The specific error message I get, when it gives me an error code which it doesn't always, is "Error 3007."

I too have followed all the suggested "fixes," including:

  • Defaulting my router to factory settings
  • Deleting cache folders
  • Disabling internet security/firewall/antivirus
  • Ensuring all my drivers are up to date
  • IP Reset (Release/Renew/DNS Flush)
  • Power cycling the router
  • Setting "Secondary Logon" protocols to "Automatic" in Windows
  • Two fresh installations of the game, one on a traditional platter drive and the other on my solid state drive.


The one suggestion they give (Their #1 in the official tech support guide) that I cannot follow is to connect directly to my modem, bypassing my router. I cannot do that as they're the same device, as they are for most people on modern ISPs.

Either way, none of the above has even come close to reducing the frequency of this problem (Actually, I'd say it's getting even worse) much less resolving it.

One last thing, this isn't isolated to Barbarians. I say that because some people speculate in this thread that it's somehow connected to playing Barbarians. I do not play a Barbarian, and this error occurs for me with the same frequency when playing either my Demon Hunter, or my Wizard.

Sigh...
Reply Quote
It's not just for WW barb I get this issue on any char anywhere anytime it only started since last patch, it's sad to think Blizzard always blames everyone's pc/router for the issue when it only ever seems to be introduced to the game after a patch!
Common Blizzard get your !@#$ together and man up that something in your patch as usual f*cks the game up!
Reply Quote
Yes, yesterday there were not too many. Today there are heaps. It ruins the game. I have been meaning to challenge the Ubers by myself on MP9, but don't want to risk the disconnect.
Reply Quote
Having the same problem with my WW Barb!

Sometimes I can play for hours without disconnects, then i get several disconnects after each other.

Definitely has nothing to do with the internet connection..
Reply Quote
Posts: 10
yeah i tried that didn't really help im using an Ethernet cable to after deleting the game and reinstalling it still kicks me out randomly.
Reply Quote
I've been getting disconnects like crazy also. Today I tried for my lunch break and was disconnected from battle net after being in game for about 10 seconds. This is getting ridiculous. It's even worst since we're hearing nothing from any blues about it. I'm going to hang in there a while longer, but I am starting to lose my desire to play this game...
Reply Quote
For me this happens when i leave the game on and go to do something else like fix dinner or whatever. when i'm playing it never disconnects. it only does it when i leave it idle. i can play for hours and nothing happens. but when i leave it idle for 5 minutes its gone.
Reply Quote
90 Blood Elf Mage
6175
Posts: 26
same thing. I get random disconnects since last week, everyday. Is there a fix yet? are there certain ports I need to have open besides the normal Blizz ports for WoW? please help this is really ANNOYING!!! It does ruin the game play experience.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]