It happend to me a few times: when I unchecked "enable music" and I clicked apply/accept "enable monster power" was automatically unchecked. It not happens all the time.