Diablo® III

Diablo 3 Client lost connect issues and more

91 Undead Warlock
Oz
6495
Posts: 4
I was joining my friends for a simple run. As soon as I connected I got d/ced the first time. Other times I joined after that I could walk around for a minute or so then got d/ced again. I tried restarting the client and my computer and still no luck. So I uninstalled Diablo 3 then guess what? It wouldn't reinstall and told me to contact tech support so here I am. Go figure right guys? >.> Welcome to blizzard gaming.
Reply Quote
Technical support is this way --------> http://us.battle.net/d3/en/forum/5386227/
Reply Quote
91 Undead Warlock
Oz
6495
Posts: 4
Be that as it may the link they gave me brought me here. Derp.

~****Update: I was able to get the game reinstalled after countless tries. Still getting d/ced every time I join a game though.****~
Reply Quote
The link they gave is wrong for tech support. If its a message the client gives when installing then maybe you should file a bug report. ;p
Edited by Rapap#1672 on 3/31/2013 10:44 AM PDT
Reply Quote
91 Undead Warlock
Oz
6495
Posts: 4
Tried too. And yet again I was brought here. We can go back and forth on this all day.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]