Summary:

* Restriction on Title Length prevented me from clearly stating my Problem in the Title, which is:

Downloading Additional Content Problem/Bug (on Americas Server) after I completed downloading, installing, and playing on the 1.08 Public Test Realm

* System basic specs: Windows XP, Intel Core2Duo E8400 with NVIDIA Geforce GTS 450

*NOTE: I have searched through the forums regarding "Downloading Additional Content" but as far as I read no blue post has ever deigned to address the issue, much less offer a solution. Furthermore, although the issues posted in other topics are similar to mine, AFAIK no one has made a connection between this problem and installing the PTR.

Details:

I downloaded the PTR over 2-3 days (I am in SE ASIA so my time difference is +0800 GMT) and I just finished it this morning after leaving the downloader on overnight. I closed the downloader.

I opened the 'normal' Diablo III client and tried to log on to my characters on the Americas Server.
No problem logging in but the moment I tried to enter a game it shows a loading screen with the message "Downloading Additional Content" with 5 Red Diamonds that show download progress. I waited a few minutes and closed Diablo (Alt+F4) since I'm thinking (and rightly so) that this shouldn't happen at all.

Then I started researching the internet for a fix, to no avail.

Then I tried playing on the PTR, which works flawlessly. NOTE: No Downloading Additional Content screen whatsoever.

I have tried deleting the Battle.Net and Blizzard Entertainment folders (in All Users->Application Data) and logging in again, but the same issue persists.

While I am writing this I am waiting out this loading screen on the Americas Server.

It actually just finished now after arnd 20-30 mins. (estimate). I just switched to the Diablo screen and I saw my monk in-game in Act 3 Hell with the message that I've been disconnected from the game. I hope the issue will not repeat but the fact is that the downloading should NEVER have taken place at all if there wasn't some sort of bug/technical problem related to downloading the PTR and how it affects the normal install of Diablo 3.

EDIT:

So after being disconnected from the game, I immediately try to re-enter the game with the same character, and the "Downloading Additional Content" screen pops up again - this time at 3 bars and as I am writing this it seems to be taking longer than the last time. So problem unsolved... and HELP STILL REQUIRED.


Any insight/response from a blue would be most helpful. And any corroboration from fellow Diablo 3 gamers would similarly be useful in validating my experience.

Thanks!
Edited by BlinkIPhaede#1268 on 4/16/2013 8:39 PM PDT