Diablo® III

Insane Stuttering / Lag

Within the last week I have been getting massive lag and stuttering spikes while playing. I'm starting to see other threads pop up about this issue as well. So I see I'm not alone.

When I been really getting hammered with these issues while in game. I'm doing the following.

1. First joining the game I created.

2. Using Wave Points

3. Getting into big groups of monsters, with elites spamming. ( Lag was never there before. Yes my computer is powerful enough to handle Diablo 3, heck I had no problem with the lastest Crysis game.)

4. Sometimes I get hit hard with the pop up boxes, killing bonus, objects and even quest.

5. Going through a portal going back to town is really bad!

I have ran a tracert and I everything looks perfectly fine. My average connection WHILE in game is usually around 85 to 105ms.

Here lately I have been getting spikes all the way up and over 2000ms.

Suggestions/ Solutions?
Edited by WhatHitYou#1829 on 4/29/2013 8:53 AM PDT
Reply Quote
So all of us that are experiencing these horrendous lag spikes and stuttering just going to get ignored over here? I have been running the game for almost a year now perfectly fine and all of a sudden I'm ( and a lot of other people ) started getting these spikes. Some type of feedback would be nice, or acknowledge that you guys are looking into it.

I'm getting tired of making a game and going to a wave point. Then moving 3 feet, then get stutter stutter stutter " You have died " lag and more stuttering.
Reply Quote
Maintenance seemed to fix this issue for me.
Reply Quote
Posts: 12,131
View profile
Its worse for me right now.
Reply Quote
Agreed. As fart as I remember this lag issue is due to people logging into the Battle Net servers. Still an issue after all this time.
Reply Quote
Well it was short lived. I'm getting hammered with the stuttering and lag again. Everything worked fine the last 2 days!
Reply Quote
Well I ended up doing a pathping that blizzard has for us. Low and behold one of my nodes is giving me 100% packetloss. Which would explain the insane stuttering. So I guess I'm pretty much screwed, unless I can get a hold of the node provider. Which I'm not even a client of.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]