Diablo® III

failed to download a required file. Please ch

Hi guys,

I had the same issue and tried everything mentioned here, and the result was zero.
So I just uninstalled the game completely, and clean up my drive C: (I'm using CCleaner) and I installed the game back and everything is back to normal.

Hope this helps :)
Reply Quote
Uninstalling and reinstalling did the trick for me too.
Reply Quote
thanks a lot. your suggestion worked out well.
Reply Quote
I take it back. It worked until I had to restart my PC and then the same error occurred again.

So I then reinstalled it once more - and once again, it worked for a while and then it stopped.

Have also tried this method here: http://patchup.info/d3/tfil/SEA/ a few times but no joy.

Anyone else have better ideas?
Reply Quote
Ok.

This made it work for me:
1. Delete C:\ProgramData\Blizzard Entertainment\Battle.net\Cache
2. Delete C:\ProgramData\Battle.net

---
Addendum:

Ok this is insane. After starting it once, and then shutting it down, I see the same problem again. I now have to delete the above folders each time I want to play the game? This is not logical at all.

:/
Edited by DaMooi#6163 on 5/12/2013 8:29 AM PDT
Reply Quote
After I've managed to get the launcher up and running, I used Help - Repair Tool and now the launchers runs consistently again.

Why I need to do this after months of no problems still eludes me.

But all good now!
Reply Quote
Same problem has come back for me.
Reply Quote
i have this problem now, any way to fix it yet?
Reply Quote
06/17/2013 12:34 AMPosted by AndrewRubio
i have this problem now, any way to fix it yet?

These are the first steps you should try to fix the issue:
  • make sure windows is fully updated and the updates are installed.
  • make sure to run D3 in administrator mode
    • right-click the D3 shortcut and hit properties
    • left-click the "compatibility" tab
    • check "run this program as an administrator"

  • disable your antivirus, popup blocker, firewall, etc. temporarily while it updates.

    if this doesnt solve the problem try deleting the battle.net folders.
    here is a link to how to make a batch file to delete the folders. that way anytime you want to delete the folders you dont have to go looking through your computer. just double click and tell it what you want to delete. easy stuff :)
    http://us.battle.net/d3/en/forum/topic/9309381243#3

    ..and if you just want to go delete them yourself someone posted the paths above
    http://us.battle.net/d3/en/forum/topic/8796449922?page=2#25
    Edited by Morogoth#1321 on 6/17/2013 12:47 PM PDT
    Reply Quote
    how to do run as administrator for windows XP?
    Reply Quote
    i open "Diablo-III-setup-enUS" and i click install and it goes to the launcher and then it pops up failed to download required file.
    Reply Quote
    Ok never mind, i called blizzard tech support and they helped me fix my problem, and thank you all for the help too. :)
    Reply Quote

    Please report any Code of Conduct violations, including:

    Threats of violence. We take these seriously and will alert the proper authorities.

    Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

    Harassing or discriminatory language. This will not be tolerated.

    Forums Code of Conduct

    Report Post # written by

    Reason
    Explain (256 characters max)
    Submit Cancel

    Reported!

    [Close]