Diablo® III

Server are up and can't play

90 Blood Elf Paladin
0
Posts: 27
I have done everything you have said araxom, but it is still looping. i'm gonna go ahead and uninstall and reinstall it since i have no other ideas. let ya know if that works

This is unacceptable. Nearly EVERY patch we get problems. This does not happen with other teams. Sure, there might be a bug on a patch here or there for other games, but they are usually fixed within 48 hours. Are the devs doing this to spite us? Did they simply go to school for programming and skip hands-on time?

I was able to connect without a problem pre-1.08. Then I had problems connecting with 1.08. Finally got this game working 2 days ago, and NOW I have problems again. Starting to enter Techland territory with bugs, and Gearbox with PR.

Pushing your luck...I'm losing the last of my patience and faith in this team.

you are an impatient child with keyboard rage
Reply Quote
I have done everything you have said araxom, but it is still looping. i'm gonna go ahead and uninstall and reinstall it since i have no other ideas. let ya know if that works

This is unacceptable. Nearly EVERY patch we get problems. This does not happen with other teams. Sure, there might be a bug on a patch here or there for other games, but they are usually fixed within 48 hours. Are the devs doing this to spite us? Did they simply go to school for programming and skip hands-on time?

I was able to connect without a problem pre-1.08. Then I had problems connecting with 1.08. Finally got this game working 2 days ago, and NOW I have problems again. Starting to enter Techland territory with bugs, and Gearbox with PR.

Pushing your luck...I'm losing the last of my patience and faith in this team.

you are an impatient child with keyboard rage


Hey, whatever you wanna believe. If you don't think this is horrendous, then you are blind.
Reply Quote
Hello,

Im a Europe user and i had this problem after logging in. Somehow my client got set to American zone and i got the wrong patch. I solved this by deleting the battle.net tools folder, and rewerting my install to a earlyer stage.

First delete the battle.net tools folder.

then do these steps, http://us.battle.net/d3/en/forum/topic/5870687669

Regards
JonJon
Reply Quote
Support Forum Agent
Posts: 914
Thanks for the update JonJon. If there's anyone else who is still affected by the looping issue for whom the steps that were presented here did not help, please contact us so that we can troubleshoot this in more detail for you. We'll continue to have our webchat available through 6p PDT this evening.

Regards,
Araxom
Reply Quote
Most of the time I have seen this error when people plays in a language different than Americas ones with US launcher... Switch to English, patch, and then switch back to whatever language you were using before, and that should do the trick.
Reply Quote
Same problem for Asia servers... If anyone cares to know...
Reply Quote
Ok i have the european client, on the server status page it says server available but i get a cannot connect error
Please fix it or tell me how to fix it.
Internet and everything is fine, played yesterday.
Got the update loop and reinstalled the client and now this.

greets
Reply Quote
Hi,

Same problem here, cannot connect on European servers.
Did not play yesterday and have not had any problems with update loop.

Thanks
Reply Quote
This happens to me EVERY SINGLE patch. I have tried all the Bliz suggestions in this thread and that I can find and nothing works.
Its been 10 hours now and still the same 'You need to Download the Latest Patch' loop junk.

So sick of the poor experiences Blizzard. Sort your game out.
Reply Quote
Still can't fix looping... I use The Americas server - looping, tried EU - loops also, however when I tried Asia server it logged me in up to the game...

Tried deleting folder, even followed the steps for downloading the updated battle.net tools and even fixing it with the repair tool in the launcher, still looping for Americas and EU for me

Current patch version at the bottom is 1.0.8.16416, HELP!!!

EDIT: I somehow managed to fix mine, I tried going to all servers and patching them up, US then Asia then EU, seemed the launcher patched every time when the loop error for each server came up. I can now log into US server. Thank god for human persistence :P

Patch version updated to 1.0.8.16603 for me...
Edited by tzurutzi#6866 on 5/14/2013 11:59 PM PDT
Reply Quote
Am experiencing the patch loop now, has been occuring for about 40 mins maybe, have tried using the updated agent + client but i still have the loop. Judging be some recent other posts i'm guessing this is a server issue....

My client also shows the current patch version to be 1.0.8.16416
Reply Quote
This happens to me EVERY SINGLE patch. I have tried all the Bliz suggestions in this thread and that I can find and nothing works.
Its been 10 hours now and still the same 'You need to Download the Latest Patch' loop junk.

So sick of the poor experiences Blizzard. Sort your game out.


I get this nearly everytime I play the game.
Reply Quote
I'm an Europe player too, but I play on Asia server and even after following JonJons steps and deleting the Battle.net folder I still get the patch loop which is veeeery annoying...
Reply Quote
Every time a patch appears, I have problems. Can we not have any more pathetic patches?

I have that same loop problem. Asia Server.

I've tried deleting battle.net folder and also to login to EU server and logout Asia. Sure, it downloads the patch again but then the same loop appears.

Currently vowing NOT to invest any more future money to Blizzard games.

Last resort. Uninstall - and installing the game currently.
If it fails I'm getting other nicer games WITHOUT patches with bugs!
Reply Quote
MVP - Technical Support
Posts: 25,252
View profile
Remember, if you have the Americas client you will NOT be able to log in to Asia or EU servers until those servers are brought down for Maint and patched. The client version software and server version have to match. In this case they do Americas first, then EU, and the next day usually Asia.

The only way to make this stop permanently is to un-install the default client and then download and install the client for the server region you prefer.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]