Diablo® III

**Nvidia GPU Users** Smooth Graphics Fix

This is how I fixed my stuttering graphics. I have a 580gtx btw...current driver 314.22

Nvidia control panel settings->

Ambient Occlusion - Off
Anistropic filtering - User's choice start low first
Antialiasing FXAA - Off
Antialiasing Gamma Correction - Global (On)
Antialiasing mode - Application Controlled
Antialiasing Setting - Application Controlled
Antialiasing Transparency - Off
CUDA - GPU - Global (All)
Maximum Pre-Rendered Frames - Use 3d Application Setting
Multi-Display/mixed-GPU Acceleration - Single Display Performance Mode
Power Management - Prefer Maximum Performance
Texture Filtering Anisotropic Sample Opti... - Off
Texture Filtering Negative LOD Bias - Clamp
Texture Filtering Quality - Quality
Texture Filtering Trilinear Optimization - On
Threaded Optimization - Auto
Triple Buffering - Off
Texture Filtering Anisotropic filter optimiz... - Off
Vertical Sync - Use 3d Application Setting

Now find your D3prefs.ini file in your User -> My Documents -> Diablo 3
Right click -> edit
Find HardwareClass "#" Change # to 1 and Save/Exit

If you are having crashing problems as well and you are using windows 7 or later.
Find your Diablo3.exe -> right click -> properties -> compatibility tab
Check Run this program in compatibility mode for: Select Windows 7 in drop-down Save/Exit

Whenever you run Diablo 3 instead of double clicking the icon right click and run as Administrator.

In game settings
In graphics tab uncheck every box EXCEPT V-Sync
Set all drop-down menu graphics options to lowest values. Increase as FPS allows.

Goodluck! Hope to see you in game.
Reply Quote
glad it works for you.
personally i have my hardware class set to 6 with no problems and i run a 560ti. i did this on purpose btw. setting it to 1 you miss out on a lot of graphics features.

i can post my nvidia settings, prefs, and system summary if anyone wants to look at these to see what i have going on.
Edited by Morogoth#1321 on 6/3/2013 10:42 AM PDT
Reply Quote
just helping others with stuttering graphics probs. just giving bare minimum specs. They can go from there. But, this is a good starting point. :)
Reply Quote
06/03/2013 07:35 PMPosted by Zyron
I'de like to try this OP, but I seem to be blocked from opening "nvidia control panel", strange.


try reinstalling your graphics driver.
when you do make sure to go to "custom" and "clean install"
that way it removes all the previous stuff
Reply Quote
Do you mind posting your settings?
Reply Quote
use adaptive vsync instead and turn off in-game vsync

if you want an even sharper d3 override the anti-aliasing setting
I play at 32x AA with sli 580's
Edited by SirWaWa#1337 on 6/16/2013 8:42 AM PDT
Reply Quote
06/16/2013 03:52 AMPosted by Nuge
Do you mind posting your settings?


these are what mine are set to:

Nvidia Control Panel
http://imageshack.us/a/img28/4835/nvidiasettings.jpg

D3 Preferences
  • in game:http://imageshack.us/a/img826/6479/d3ingameoptions.jpg
  • in the text file:
    • PreferencesVersion "44"
      PlayedCutscene0 "15"
      PlayedCutscene1 "15"
      PlayedCutscene2 "23"
      PlayedCutscene3 "143"
      DisplayModeFlags "0"
      DisplayModeWindowMode "2"
      DisplayModeWinLeft "423"
      DisplayModeWinTop "11"
      DisplayModeWinWidth "1250"
      DisplayModeWinHeight "1025"
      DisplayModeUIOptWidth "1920"
      DisplayModeUIOptHeight "1080"
      DisplayModeWidth "1920"
      DisplayModeHeight "1080"
      DisplayModeRefreshRate "60"
      DisplayModeBitDepth "32"
      Gamma "1.000000"
      MipOffset "0"
      ShadowQuality "6"
      PhysicsQuality "1"
      ClutterQuality "3"
      Vsync "0"
      Letterbox "0"
      Antialiasing "0"
      LowFX "0"
      LockCursorInFullscreenWindowed "0"
      LimitForegroundFPS "0"
      MaxForegroundFPS "200"
      LimitBackgroundFPS "0"
      MaxBackgroundFPS "200"
      DisableTrilinearFiltering "0"
      ColorCorrection "1"
      MipBias "0.000000"
      ReflectionQuality "1"
      TonemapExposure "3.000000"
      TonemapContrast "2.000000"
      TonemapSaturation "2.000000"
      TonemapGain "2.000000"
      HardwareClass "6"
      PCIVendor "4318"
      PCIDevice "4608"
      MasterVolume "0.500000"
      EffectVolume "0.500000"
      MusicVolume "1.000000"
      NarrationVolume "0.500000"
      AmbientVolume "0.500000"
      ChannelsToUse "32"
      SoundDriver "0"
      SpeakerMode "2"
      ReverseSpeakers "0"
      QuestSubtitlesEnabled "0"
      CinematicsSubtitlesEnabled "0"
      MuteSound "0"
      MuteEffects "0"
      MuteAmbient "0"
      MuteVoice "0"
      MuteMusic "1"


    My PC specs:
      Summary
      Operating System
      Microsoft Windows 7 Professional 64-bit SP1
      CPU
      Intel Core i7 960 @ 3.20GHz 62 °C
      Bloomfield 45nm Technology
      RAM
      6.00GB Triple-Channel DDR3 @ 519MHz (8-8-8-19)
      Motherboard
      Gigabyte Technology Co., Ltd. X58A-UD3R (Socket 1366) 59 °C
      Graphics
      VE248 (1920x1080@60Hz)
      2048MB GeForce GTX 560 Ti (Undefined) 87 °C
      Hard Drives
      932GB Western Digital WDC WD10EADS-11M2B2 SCSI Disk Device (SATA) 31 °C
      335GB ST3360320AS SCSI Disk Device (SATA) 35 °C
      466GB Western Digital WDC WD50 00KS-00MNB0 SCSI Disk Device (SATA) 46 °C
      Optical Drives
      ASUS DRW-24B1ST a SCSI CdRom Device
      Audio
      Creative Audigy Audio Processor (WDM)

    *CPU is overclocked to 3.8Ghz
    Edited by Morogoth#1321 on 6/16/2013 8:52 AM PDT
    Reply Quote
    Again no changes, must be hardware problem for me.
    Reply Quote

    Please report any Code of Conduct violations, including:

    Threats of violence. We take these seriously and will alert the proper authorities.

    Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

    Harassing or discriminatory language. This will not be tolerated.

    Forums Code of Conduct

    Report Post # written by

    Reason
    Explain (256 characters max)
    Submit Cancel

    Reported!

    [Close]