Diablo® III

Failed Retrieve Blizzard Launcher Properties

So I was re-installing D3 the other day, to try to get rid of the annoying "Checking for Updates" screen that never goes away, and I got this when the game finished installing.

Is this possibly what could be causing the launcher to be unable to find updates? I think I remember it happening before, on one of the installs that I had the issues with.

For clarity, I just installed D3 on my laptop, didn't get the Blizzard launcher error when the install completed, and have no issues whatsoever starting the launcher or game. That's what made me think that the Blizzard launcher error could be the issue.
Reply Quote
Bumping this to 1st page so that a Blue can answer my question...
Reply Quote
Support Forum Agent
Posts: 35,680
S1ic3r,

One other user seems to have the same issue but they didn't reply when I asked for a bit of information.

http://us.battle.net/d3/en/forum/topic/9245734932

What steps have you tried so far? Have you temporarily disabled or removed any internet security apps? Run as an admin? Deleted the C:\ProgramData\Battle.net and Blizzard Entertainment folders? Tried creating a new Admin user account and using that?

You haven't used it in a while but if it's still installed, does StarCraft II do the same thing when launched?
_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
C:\ProgramData\Battle.net

I don't have a folder named that.

The closest thing I have is C:/ProgramFILES\DIABLO3\BNET

So I don't know what to do. Is that the one I should delete? If so it didn't work anyways. Did I break my computer by doing that? Help!?
Reply Quote
@Clack: http://us.battle.net/support/article/6231 indicates how you can show hidden files & folders, which ProgramData is, by it's nature. That should help you find the right folder Omrakos is asking about.
Reply Quote
Little late to this thread but I just had this problem as well. Tried the steps suggested and no luck. Any advice?
Reply Quote
Support Forum Agent
Posts: 35,680
DeathbyMoke,

Could you try the steps in this support article please? Be sure to also do the Advanced Troubleshooting steps if necessary.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]