Diablo® III

Diablo III Setup won't run

I have a macbook for testing at work and im thinking about doing a little bit of play on it as well. Its running the latest OS X 10.8.4 and I have WoW and SC2 installed on it successfully..both are up to date and launch ok. However, I have downloaded the D3 installer (Diablo-III-Setup-enUS.zip) from my account page on battle.net, extracted it (Diablo III Setup) and when I "run" it nothing opens. Nothing happens, no new processes are visible, nothing. Crickets chirping.

Any idea what could cause this? Rebooted already, redownloaded already, same result.
Reply Quote
Support Forum Agent
Posts: 928
Hi Zone, you may be using a 3rd party app to unzip the file. Please check out the troubleshooting on this page and if that doesn't do the trick, go ahead and respond here. I'll keep an eye out in case you still need further assistance.
Reply Quote
That was it, thanks! Crazy, I was using unzip via shell (im a unix guy, but not an apple/mac guy so I tend to favor the command line with this OS) and as soon as I extracted it with the apple tool instead, it worked fine.

As an interesting FYI the same problem was happening with my WC3 installer downloads (base & frozen throne) however wow & sc2 both had no issues.

Thanks for your reply!
Reply Quote
Support Forum Agent
Posts: 119
Glad to see that this helped out :)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]