Diablo® III

Weird Graphics Issue

I recently built a new computer and experienced this issue both on my old computer and my new computer with the same graphics card/driver.

I have a EVGA GTX 770 with the most up to date drivers.

I have a 3d monitor and this issue occurs with 3d nvision 2 turned on or off. It's much more noticeable when I have 3d turned on, though. The issue is that when I play in a game, with any character, when I move around weird lines will come out of the different player models. Sometimes it's the player model themselves, sometimes it's the shadow, but something is rendering incorrectly and causes these lines to pop out of my characters. I have two images below where you can see what I'm talking about. From time to time the shading on the ground will be completely off as well. I also had this issue on a different graphics card, EVGA GTX 660 TI but that issue only started to occurr after I updated to the most up to date drivers. The problem with the GTX 770 is that the most up to date drivers are the only drivers available for that video card, since it's new. Is there anything that can be done to fix this problem?

http://i.imgur.com/NEkWabd.jpg

http://i.imgur.com/4f3nBw6.jpg

And finally one more weird thing. When I view my monks profile he has a very, very long ring finger. [I can't help but say the ladies would love this]

http://i.imgur.com/6gt7qgE.jpg
Reply Quote
I had this happen once in the game tonight, along with a few other graphical glitches (characters/items disappearing, floating swords and shields, etc.). The effect fixed itself when I died during battle, which warped me to a different area, and the problem disappeared.

I'm using an AMD Radeon HD 6770 card with 1 GB of video memory.
Reply Quote
This is pretty consistent for me. =[

CPU Vendor: Genuine Intel
CPU Details: Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz
CPU Processors: 1
CPU Cores: 4
CPU Threads: 8
8136.55 MB of total physical memory
****** Graphics Device Info ******
NVIDIA GeForce GTX 770 (2 GB)
Edited by intrus0x9#1864 on 6/14/2013 12:04 AM PDT
Reply Quote
Support Forum Agent
Posts: 37,183
intrus0x9,

Ordinarily I'd be inclined to suggest other drivers but you're right, Nvidia doesn't seem to have any besides the latest release. That doesn't leave us with much to try really.

Things you might try just to gather more data would include lowering the clock speed on the video card with a utility like MSI's Afterburner. I'd lower it as much as 50% just to see if it made a difference or not first.

It could just be a defective card too but it's unlikely you have a second one to swap it out with and there's no evidence just yet to recommend RMA'ing it.

You might try reinstalling the Nvidia drivers anyway but leave out all of the optional components for now, just installing the graphic drivers. Use their Custom and Clean Install options.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
I have the same problem. I'm actually glad you have the same problem, feared my graphics card was defective. I'm going to see if there is a beta driver at nvidia. If there is one it will work with your graphics card as well since it's a new driver. If it works I'll let you know. PS: my monk has a weard spike sticking out of his head... Normal fingers though. :p

EDIT: Unfortunately this didn't help. Downgrading to previous driver (I have a GTX 580). If that doesn't help either, it must be a glitch in Diablo 3. A new one...

EDIT: Older driver installed and no more weird glitches in 3D Diable 3. Check with Nvidia if they can help. The driver is to blame :)
Edited by KingmA#2766 on 6/21/2013 11:02 AM PDT
Reply Quote
could it have to do with VSync?
Reply Quote
Posts: 2
same problem here 2 x 770 sli gtx asus direct cu II cards
intel i73930k 4.2 ghz
asus rampage formula 2011 socket
4x4 corsair vengenace 2400 speed running at 2333
1000 w seasonic modular
corsair 100i water cooler
haf 932 advanced case
lg blueray burner
areocool 5 fan controller touch screen
all custom fans and led lighting

http://www.youtube.com/watch?v=BXSmIEvG_Hc
Edited by Smeekillerr#1503 on 7/12/2013 7:10 AM PDT
Reply Quote
Support Forum Agent
Posts: 37,183
Smeekiller,

I'm not sure what your video is trying to show, but what driver release are you currently using? You should be on 320.49. 320.18, I believe is having issues so they're not recommended right now.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
Is this the only driver you have ever installed on that machine. If not you can use" install prior driver"
Reply Quote
If you do a new install make sure to choose custom and check on Clean Install. This will properly remove your prior driver, The old way of uninstalling using Windows uninstall is no longer adequate.
Reply Quote
I'm having the exact same issue with the exact same video card.

CPU: i5-4670
Mobo: Asus Sabertooth Z87
RAM: 16G Corsair
SSD: Corsair Neutron

Rig was professionally built, QC Checked and burned in. Yes, all the drivers are current.

The game occasionally freezes and the latency indicator goes red, and recovers in 5-15 seconds. I don't have this issue playing D3 on my wife's Mac on the same Comcast connection. I have actually gotten scared to play my 52 HC Monk.

In addition to this, there seems to be some artifacting with ambient shadows. Both my warriors are missing the rendering of their right arms. There are other minor rendering problems with my DH and Monk.

Things get really bad when I enable 3D vision. The ray artifacting gets really bad and shadows are completely borked. It's basically unplayable in stereoscopic.

I have played BF3, GW2 and Arkham City all in 3d and with zero issues. Ironically, the only game I have had issues with so far, is the one that's the least demanding on my system...D3.

**Edit**
The freezing/lag issue has been fixed by disabling windows indexing as suggested in this thread

http://us.battle.net/d3/en/forum/topic/5978349974?page=18#352
Edited by Cymek#1810 on 7/22/2013 9:46 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]