Diablo® III

Stuttering in Diablo 3.

Hi guy,

Here is my issue. I just got back to D3 after switching to a significantly newer and more powerful laptop. The problem is, now the game stutters non-stop to the point of being unplayable. It doesn't matter if I am by myself or with others.

I've searched the internet and have tried the following solutions but none are working:
  • Adjust program settings in NVidia Control Panel; set to single display mode, prefer maximum performance, vertical sync (adaptive).
  • Set Diablo 3 folder as an exception in AVG.
  • Set to compatibility mode.
  • Set to higher priority.


None of the above options are fixing it. I'd love to play this game, I just can't. Any recommendations/advice? My rig runs Windows 8.0; dual NVidia GT 650.
Edited by Firu#1124 on 7/1/2013 12:29 PM PDT
Reply Quote
Posts: 10,215
View profile
that gt 650M performance score makes me sad :(
http://www.videocardbenchmark.net/gpu.php?gpu=GeForce+GT+650M&id=122
no doubt its probably causing you issues.
Reply Quote
Hm, but I played D3 with no stuttering on a far worse card. Regardless of the setting (low, high, etc.) the game still stutters like a fiend.
Reply Quote
Posts: 10,215
View profile
07/01/2013 12:44 PMPosted by Firu
Hm, but I played D3 with no stuttering on a far worse card. Regardless of the setting (low, high, etc.) the game still stutters like a fiend.


what was your card before?

also maybe you can post your DXDiag and D3Prefs. that way more help can be given.
Reply Quote
I forget the exact name - it was a 4 year old ATI though. (I think it was an ATI HD5650.)

D3 is below.

PreferencesVersion "44"
PlayedCutscene0 "7"
PlayedCutscene1 "12"
PlayedCutscene2 "0"
PlayedCutscene3 "0"
DisplayModeFlags "0"
DisplayModeWindowMode "0"
DisplayModeWinLeft "320"
DisplayModeWinTop "156"
DisplayModeWinWidth "1280"
DisplayModeWinHeight "720"
DisplayModeUIOptWidth "1920"
DisplayModeUIOptHeight "1080"
DisplayModeWidth "1920"
DisplayModeHeight "1080"
DisplayModeRefreshRate "60"
DisplayModeBitDepth "32"
Gamma "1.000000"
MipOffset "0"
ShadowQuality "4"
PhysicsQuality "1"
ClutterQuality "2"
Vsync "1"
Letterbox "0"
Antialiasing "1"
LowFX "0"
LockCursorInFullscreenWindowed "0"
LimitForegroundFPS "0"
MaxForegroundFPS "150"
LimitBackgroundFPS "0"
MaxBackgroundFPS "8"
DisableTrilinearFiltering "0"
ColorCorrection "1"
MipBias "0.000000"
ReflectionQuality "0"
TonemapExposure "1.900000"
TonemapContrast "1.500000"
TonemapSaturation "1.000000"
TonemapGain "1.000000"
HardwareClass "3"
PCIVendor "4318"
PCIDevice "4049"
MasterVolume "1.000000"
EffectVolume "0.800000"
MusicVolume "0.800000"
NarrationVolume "0.800000"
AmbientVolume "0.800000"
ChannelsToUse "64"
SoundDriver "1685181330"
SpeakerMode "2"
ReverseSpeakers "0"
QuestSubtitlesEnabled "1"
CinematicsSubtitlesEnabled "0"
MuteSound "0"
MuteEffects "0"
MuteAmbient "0"
MuteVoice "0"
MuteMusic "0"


DXDiag is below:
------------------
System Information
------------------
Time of this report: 7/1/2013, 15:54:02
Machine name: PSD
Operating System: Windows 8 64-bit (6.2, Build 9200) (9200.win8_gdr.130410-1505)
Language: English (Regional Setting: English)
System Manufacturer: LENOVO
System Model: 20193
BIOS: 6BCN40WW(V2.00)
Processor: Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz (8 CPUs), ~2.4GHz
Memory: 12288MB RAM
Available OS Memory: 12236MB RAM
Page File: 4063MB used, 9899MB available
Windows Dir: C:\windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: 120 DPI (125 percent)
System DPI Setting: 120 DPI (125 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.02.9200.16384 64bit Unicode

------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: NVIDIA GeForce GT 650M
Manufacturer: NVIDIA
Chip type: GeForce GT 650M
DAC type: Integrated RAMDAC
Device Type: Full Device
Device Key: Enum\PCI\VEN_10DE&DEV_0FD1&SUBSYS_397217AA&REV_A1
Display Memory: 4038 MB
Dedicated Memory: 1990 MB
Shared Memory: 2048 MB
Current Mode: 1920 x 1080 (32 bit) (59Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: unknown
Monitor Id: LGD01E9
Native Mode: 1920 x 1080(p) (59.934Hz)
Output Type: Internal
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 9.18.0013.2049 (English)
Driver Version: 9.18.13.2049
DDI Version: 11
Feature Levels: 11.0,10.1,10.0,9.3,9.2,9.1
Driver Model: WDDM 1.2
Graphics Preemption: DMA
Compute Preemption: DMA
Driver Attributes: Final Retail
Driver Date/Size: 6/21/2013 08:06:36, 15144928 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
Device Identifier: {D7B71E3E-4C91-11CF-1B7C-7F191CC2C435}
Vendor ID: 0x10DE
Device ID: 0x0FD1
SubSys ID: 0x397217AA
Revision ID: 0x00A1
Driver Strong Name: oem64.inf:0f066de3d6a0b0c5:Section197:9.18.13.2049:pci\ven_10de&dev_0fd1&subsys_397217aa
Rank Of Driver: 00E00001
Video Accel: ModeMPEG2_A ModeMPEG2_C ModeVC1_C ModeWMV9_C
Edited by Firu#1124 on 7/1/2013 12:57 PM PDT
Reply Quote
FIXED! So far at least.

This might work for other Nvidia users. The issue appears to be tied towards PhysX / "CUDA - GPUs". My best interpretation is that there appears to be a conflict within the Diablo programming somewhere as to which RAM to use (CPU vs Graphics Cards, etc.).

Look in the NVIDIA Control Panel, under Manage 3D Settings. There is an option for "CUDA - GPUs". I selected the "Use these GPUs" and forced it to use the second of my two graphics cards. It appears to work.

Hopefully that's it.
Reply Quote
Posts: 10,215
View profile
FIXED! So far at least.

This might work for other Nvidia users. The issue appears to be tied towards PhysX / "CUDA - GPUs". My best interpretation is that there appears to be a conflict within the Diablo programming somewhere as to which RAM to use (CPU vs Graphics Cards, etc.).

Look in the NVIDIA Control Panel, under Manage 3D Settings. There is an option for "CUDA - GPUs". I selected the "Use these GPUs" and forced it to use the second of my two graphics cards. It appears to work.

Hopefully that's it.


interesting. must be a dual GPU thng.
can you try something else real quick?
reset the thing you just did back the way it was.

in the NVIDIA Control Panel under
3d settings > Set PhysX Configuration > Select a PhysX processor:

the default for this is "Auto-Select"
you can change this to either your GPU or your CPU

im just wondering if you select something here if it would make a difference also.
Reply Quote
It works best when Set PhysiX Configuration selects CPU. It removes most of the suttering when you force it to pick on particular GPU though.

Such an odd little issue.... And by little, I mean, makes the game borderline unplayable.
Reply Quote
Posts: 10,215
View profile
thanks for looking into it :)
hopefully the info helps some ppl
Reply Quote
[quote]FIXED! So far at least.

This might work for other Nvidia users. The issue appears to be tied towards PhysX / "CUDA - GPUs". My best interpretation is that there appears to be a conflict within the Diablo programming somewhere as to which RAM to use (CPU vs Graphics Cards, etc.).

Look in the NVIDIA Control Panel, under Manage 3D Settings. There is an option for "CUDA - GPUs". I selected the "Use these GPUs" and forced it to use the second of my two graphics cards. It appears to work.

Hopefully that's it.


Doesn't fix it for me, but I only have one card as well. Forcing it to pick either my card or my cpu doesn't give any difference.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]