Diablo® III

Big FPS Drop

So I've been playing Diablo 3 now for about 4 months on my labtop and before I always had a frame rate playing Diablo, at around 40 FPS, but recently my FPS has dropped drastically, so much that it is impossible to play. Now when I try to play I can only get about 10 frames per second. (This problem only occurs when playing Diablo, my computer is fine when I do anything else.) I've tried everything I could, I've deleted excess files and other games in my labtop, setting priority to high when playing Diablo, cleaning out my labtop's fan and insides and a few other things, but nothing has seemed to help at all. I had done a system check and my computer "seems" to be fine and states that there are no problems with my computer. Maybe it has something to do with my graphics card, because my FPS is low when my character is in a large map area, like the Fields of Misery, but when my character is in a small area, such as The Slaughtered Calf Inn my FPS skyrockets as high as 35 frames per second but goes back to 10 once I enter a large map again. Although, I am not too sure is it is a problem with the graphics card as I do not know too much about computers and how they work. I'm sorry for writing such a long post, I just wanted to give as much information as possible, but if anyone could please help me with my problem I would appreciate it greatly. I just want to play Diablo again ):
Reply Quote
post your DXDiag and D3prefs info
Reply Quote
Here is what looks important of the DXDiag: ------------------

System Information
------------------
Time of this report: 7/8/2013, 08:23:01
Machine name: BOODAH
Operating System: Windows 8 64-bit (6.2, Build 9200) (9200.win8_gdr.130410-1505)
Language: English (Regional Setting: English)
System Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
System Model: 355V4C/355V4X/355V5C/355V5X/356V4C/356V4X/356V5C/356V5X/3445VC/3
BIOS: P03ABF
Processor: AMD A6-4400M APU with Radeon(tm) HD Graphics (2 CPUs), ~2.7GHz
Memory: 4096MB RAM
Available OS Memory: 3548MB RAM
Page File: 1428MB used, 5702MB available
Windows Dir: C:\windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.02.9200.16384 64bit Unicode

------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: AMD Radeon HD 7520G
Manufacturer: Advanced Micro Devices, Inc.
Chip type: AMD Radeon HD 7520G (0x9990)
DAC type: Internal DAC(400MHz)
Device Type: Full Device
Device Key: Enum\PCI\VEN_1002&DEV_9990&SUBSYS_C0DD144D&REV_00
Display Memory: 1999 MB
Dedicated Memory: 482 MB
Shared Memory: 1517 MB
Current Mode: 1366 x 768 (32 bit) (60Hz)

And here are the D3prefs:

PreferencesVersion "44"
PlayedCutscene0 "15"
PlayedCutscene1 "15"
PlayedCutscene2 "23"
PlayedCutscene3 "143"
DisplayModeFlags "0"
DisplayModeWindowMode "0"
DisplayModeWinLeft "0"
DisplayModeWinTop "0"
DisplayModeWinWidth "1304"
DisplayModeWinHeight "768"
DisplayModeUIOptWidth "1366"
DisplayModeUIOptHeight "768"
DisplayModeWidth "1366"
DisplayModeHeight "768"
DisplayModeRefreshRate "60"
DisplayModeBitDepth "32"
Gamma "1.000000"
MipOffset "0"
ShadowQuality "5"
PhysicsQuality "1"
ClutterQuality "3"
Vsync "0"
Letterbox "0"
Antialiasing "1"
LowFX "0"
LockCursorInFullscreenWindowed "0"
LimitForegroundFPS "1"
MaxForegroundFPS "150"
LimitBackgroundFPS "1"
MaxBackgroundFPS "8"
DisableTrilinearFiltering "0"
ColorCorrection "1"
MipBias "0.000000"
ReflectionQuality "0"
TonemapExposure "1.900000"
TonemapContrast "1.500000"
TonemapSaturation "1.000000"
TonemapGain "1.000000"
HardwareClass "4"
PCIVendor "4098"
PCIDevice "39312"
MasterVolume "1.000000"
EffectVolume "0.800000"
MusicVolume "0.800000"
NarrationVolume "0.800000"
AmbientVolume "0.800000"
ChannelsToUse "32"
SoundDriver "0"
SpeakerMode "0"
ReverseSpeakers "0"
QuestSubtitlesEnabled "0"
CinematicsSubtitlesEnabled "0"
MuteSound "0"
MuteEffects "0"
MuteAmbient "0"
MuteVoice "0"
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]