Diablo® III

Severe rubberbanding?

Posts: 8,057
View profile
Anyone else? My little signal things on the Diablo toolbar say all green, but my actions are at least 2 seconds behind at times. What gives? Never had this issue before this bad:/
Reply Quote
I play a TR bell monk so I see this very frequently. It's usually not bad unless Blizzard's servers are having problems though.

For the 10% of the time when the servers are acting up it's better to just go play a different game. There's nothing you can do about it.
Reply Quote
Rubberbanding is the best when you pop Wrath, run into an elite pack and rubberband to death.

Thanks for the wonderful game experience blizz.
Reply Quote
Posts: 8,057
View profile
You know, I was asking the opinion of the community, not wondering the root issue of the problem. Obviously the servers are going through some stuff right now and causing crappy gameplay. But I guess thanks for moving my thread to a forum where it will receive no further recognition, and the issue will go unsolved. Gg blizz.
Reply Quote
I too I'm having the same issue. Latency bars are always green. It seems almost almost every time (no exaggeration) that I'm fighting an elite pack while Wrath is up and I try to whirlwind out, I die because on my screen it rubberbands back in to the pack and I die....what gives?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]