Diablo® III

Mac client for Diablo III doesn't run.

Hi,

I got the Diablo III client from the Battlenet website and when I unzipped the file I downloaded, there was a "Diablo III Setup.app" inside it, but when I click to run it, nothing happens.

I even copied it to my Applications folder and tried to ran from there, but when I double click on it, it doesn't react, absolutely nothing.

My OS version is 1.8.2

And my Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro9,1
Processor Name: Intel Core i7
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP91.00D3.B08
SMC Version (system): 2.1f173

Thanks.
Reply Quote
Solved. Problem was that I extracted it with WinZip and it messed the .app file up, I extracted with Archive Utility, OSX's default zip utility, and it ran.

Thanks.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]