Diablo® III

Diablo 3 cannot connect to the internet

I haven't played for a while and I decided to start up again. Whenever I attempt to load the game I get an error message that says "Failed to download a required file. Please check your internet connection and try again." I made sure to run as admin, I allowed all the necessary ports access in my firewall, I updated all my Windows 7 files, I even rebooted my modem and router and still get this message.

Is there another way to fix this problem that I have missed?

EDIT: I tried to run World of Warcraft: Mist of Pandaria and I had no problems with it.
Edited by Nian#1810 on 7/22/2013 1:26 PM PDT
Reply Quote
Support Forum Agent
Posts: 41,452
Nian,

If you're using an internet security application like an Anti Virus program, try temporarily disabling it while the game starts and tries to update.

If World of Warcraft is working for you, that eliminates quite a bit as a lot is shared between the games as far as connecting goes, but an AV program could still be exclusively blocking an update in Diablo III.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
I don't have any AV programs on my computer. Something I forgot to mention in my first post. Would turning the firewall off effect it?
Edited by Nian#1810 on 7/22/2013 1:43 PM PDT
Reply Quote
Support Forum Agent
Posts: 41,452
Nian,

No, turning it off won't cause any problems with connecting. Leaving it on and misconfigured could though.

Try this:

Create a new Windows User account and add it to the administrator group. Then log off of Windows and back on with the new user account and then try the game again.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
Still says to check my internet connection on the other user account.
Reply Quote
Support Forum Agent
Posts: 41,452
Nian,

Are you sure you've logged into World of Warcraft? It appears the last access for the Battle.net account you're posting from was last January?

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
I haven't updated it since I last played, I was able to begin the download for the latest patch for WoW.
Reply Quote
Support Forum Agent
Posts: 41,452
Nian ,

Ok, could you please try the steps in this support article next?

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
It worked. Thank you Omrakos.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]