Diablo® III

It worked a couple weeks ago...

Now its nothing but a source of frustration...

1 - account was locked - now I can login w/ browser
2 - Launcher stuck 'initializing'
3 - made sure secondary login was running
4 - Deleted all /program data/Blizzard Entertainment & /program data/ battle net.
5 - https://us.battle.net/support/en/article/BLZBNTBTS00001

NEVER AGAIN do I buy a 'battle for my account'.net game.
This is ridiculous, security...[removed]
Edited by Omrakos on 7/22/2013 6:23 PM PDT
Reply Quote
Support Forum Agent
Posts: 37,621
Hrendor,

There's a few things you'll want to check for this sort of issue.

If you happen to be using an anti-virus app, try temporarily disabling it until the game has been able to connect and be fully updated.

Make sure your Adobe Flash Reader is up to date as our Launcher uses it.

Open up your Internet Explorer browser, hit Alt-F and verify it's not been set to "Work Offline". The launcher uses some Windows settings and if it's set to be offline, it won't be able to connect properly.

You may need to perform the steps in this support article if none of the above helped.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
Support Forum Agent
If you happen to be using an anti-virus app, try temporarily disabling it until the game has been able to connect and be fully updated.
MS SecEssentials - realtime disable - NOPE

07/22/2013 06:30 PMPosted by Omrakos
Make sure your Adobe Flash Reader is up to date as our Launcher uses it.
V10.1.7 - no updates available.

Open up your Internet Explorer browser, hit Alt-F and verify it's not been set to "Work Offline".The launcher uses some Windows settings and if it's set to be offline, it won't be able to connect properly .
lol WHO uses IE?? OK - Not offline.

.You may need to perform the steps in this support article if none of the above helped.

Thanks Already did this.. .your read my post... no?
Reply Quote
wanna buy my CD key back?... its useless to me now

I know - I'm here all week... be sure to tip your waitress.
Reply Quote
Support Forum Agent
Posts: 37,621
Hrendor ,

Could you please create a new Windows User account, add it to the Administrator group, log out of Windows and back on again with the new User account, then try the game again?

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
I'm posting here because I have exactly the same issue.

I have tried all the workarounds and nothing is resolving it. Both the D3 an SC2 launchers sit at Initializing. Have run with and without administrator priveliges.

Pretty funny. I'm in no rush to play the game, I was just opening it to see if anything had changed.

I guess not :P.

Blizzard, your competitors have a distinct advantage over you now. Their players can get past the launcher :P

I'm not wasting anymore of my time trying to get past the garbage coding / design of your product. I'll try again in a few months.
Edited by Dejim#6537 on 7/24/2013 12:24 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]