Very long loading time?

Mac Technical Support
Prev 1 2 3 8 Next
Bump for a fix


I preordered ROS in the hopes that this will be fixed by 3/24
Same here. Sometimes when I arrive I am dead, others the others players have moved on quite a distance and takes forever to catch up? It is no good going back to town and using one of their flags to catch up!!

Does anyone from Blizzard read these comments????

Is this problem being looked at????

If there is few other comments

1. do you still need to beat 5 elites to get a key drop or hellfire piece? the icon for this notice has disappeared

2. can you make a few more hero slots for when the new crusader comes out. I have 1 type of hero in both hardcore and normal = 10 slots. I will have to delete 1 of these to try the new crusader. also I enjoy starting from the beginning sometimes.
Same here. Been this way for weeks ever since i upgraded to latest patch. I have Macbook Pro with Mavericks. Load times are AWFUL!! 30 seconds minimum to join or start a game. Then another 20-30 to teleport to friend. This is unacceptable and unplayable.

Please fix! Wont be buying ROS until this issue is fixed.
not to mention the LONG load times when joining or starting a game i have about a 50/50 chance of the game crashing all together and kicking me out completely. Just awful!
pre2.0 the game loads in less than 5sec using a 7200 rpm hdd. starting from pressing the resume/start button until I can move my char.

after the patch it now takes at least 17secs using the same hdd. I upgraded to a 120gb ssd but loading time is still 17sec +.
even teleporting has 2-3sec loading now. it used to be instant pre2.0.
I've set all settings to minimum but that didn't help.

My desktop has 16gb ram, i7 3.4ghz quad core, 120gb ssd.

ps. im using pc win7.
Bump! Please Fix the loading time. It's really bad! and that's the cause of the game crashing
The load times are crazy, it makes it impossible to do cota runs. This better be fixed in ros.
Still having this same problem with very long load times - creating games, waypoints, town portals, etc. Also still occasionally get booted back into the interface when trying to create a game.
bump, came back after 1.01 or whatever and it used to run 100% smooth. Now i get long load times with the possibility of the game crashing right after load. The crashes happen more frequently when i try and resume my first game. I am on early 2011 MBP with dual graphics card and 8 gigs of ram.
Same here. I'm pretty sure it has to do with entering/exiting town. Going from one area to the next without going through the town to get loads very quickly. Otherwise, entering and leaving games and teleporting to town or to a waypoint from town is pure hell to deal with. If it is happening to some PC's too maybe we'll get a fix soon :)
same situation
I'm unfortunately still experiencing this as well. 10.9.2, Sandy Bridge iMac i7-3400. 2GB 6970, 24GB RAM. (Samsung 840 Evo SSD)

It's most frustrating because not only is the occurrence random, but so is the amount of time involved in the delay. I do feel like this is Mac-specific as my home has both clients playing in games together, and in a 3-hour session, only I ever saw the issue. Literally over 50 times in said period, about perfect reproducibility.

Bottom line, until this is resolved, I have become very selective about what gear I loot, so I won't have to go back to town.
Do you guys get this problem all the time?
Does restarting Diablo III fix the issue?
Playing on EU servers and it's the same.
Long loading times to enter games and i'm disconnected from the game every time I'm entering.
It worked perfectly well before patch
Same problem here. I tried restaring D3 / rebooting / turning off everything else / restaring internet connection / simply playing for a while (warm-up) - NOTHING helps.

The game perfomance was totally okay for me and I hardly ever got disconnected. Those insanely long loading times came with patch 2.0.1, but after RoS release it all got even worse, to the point that joining a public game is almost not an option for me.
Literally every single time I teleport to someone in a rift, the game gets stuck on the loading screen and after about one minute I get DC'ed from the game... If it's a "normal" zone, my character usually drops below 50% health before I am even ABLE to see what's going on.

Please, fix it.
In the app, do you have 100% of the game downloaded?
03/27/2014 04:26 PMPosted by S4d1k
Do you guys get this problem all the time?
Does restarting Diablo III fix the issue?

this is actually your response dude? give the players some credit. restarting d3?..... The long loading times occur all the time and yes the games downloaded 100%. AND NO THIS DIDN'T HAPPEN BEFORE 2.0!
I'm wondering if this is a residual issue caused by the regonfiguration process 2.0 went through when it first came out. The timing is definitely right for that to be the case.

Could those in this thread please try the following instructions and see if it resolves the issue?

Delete the following files/folders:

/Users/Shared/Blizzard/ (if present)
/Diablo 3/Diablo 3.mfil
/Diablo III/Data_D3/PC/MPQs/Cache

Once done deleting those files, make sure all permissions are set properly in Diablo 3's main folder by doing the following:

1) Get Info (in the Finder) on the Diablo 3 folder.

2) Click the padlock icon and enter your password to authenticate yourself.

3) For the Everyone group, set it to Read and Write.

4) Click the cogwheel icon and select Apply to enclosed items. Select OK to confirm your action.

5) Close the Get Info Window.

6) Repeat steps #1-5 on the /Users/Shared/ folder.

Now run the Desktop Application. By default it automatically updates games, but if you have it set to not do this (recommended), manually click the Update button to let Diablo 3 rebuild its cache. It can take between 15-60 minutes depending on the computer and drive being used. Do not click Play until you see the Play button light up and the progress bar is no longer on the screen. The underlined part is very important as you do not want to enter the game while the cache is being rebuilt.

Give this a go and see if this helps you any.
Technical Support MVP
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.

Join the Conversation

Return to Forum