Server Disconnect - Frustrating

Aus/NZ General Discussion
So for the last few days I have been getting disconnected at random intervals when playing on the Asia server. There is nothing wrong with my Internet connection and I am connected via Ethernet.
As you can imagine it is extremely frustrating and sometimes it takes like 10 attempts to get through a dungeon without a disconnect.

Does anyone else have this issue and is there a fix for it?
No fix for it yet, I'm beyond frustration now.

Check out the threads in Technical Support, many people are experiencing this around the world.

A mate had the same issue last night, we gave up on playing due to randomly getting disconnected anywhere from a few to 20 minutes in.

No issues with my connection either (I'm playing from Brisbane on the Australian servers/Americas region). Edit: ISP is TPG

I tried killing the cache folders earlier, and letting the Bnet client reinstall the updates. No dice, instant 3007 timeout/disconnect without warning in first dungeon.
+1 what the hell blizzard ive nearly died HC like 4 times, pls fix the d/c issues ive rang my provided its not on my side
This is the reason i don't go hardcore.. Servers are unpredictable.
same here, error 3007 occurs literately every hour
Chalk up another for 3007. Same deal as well in the timing as it only started in the last 2 days. What's annoying about it is that there is no warning. I could be literally smacking something in the face and the game gives me the 3007 message and logs me out. Something ain't right here.

It has made playing solo impossible since progress resets each time. And it is completely random. I've managed to finish an act worth of bounties only for it to DC me before I can turn in it. Then happen again 5 minutes later once more after I logged back in.
Yep this is pathetic.

Makes the game unplayable as I have to repeat the same thing over and over and hope I don't get a disconnect!
Saw d1mebag's post over in the technical support thread and thought I would also join here as well.

I'm also experiencing the error 3007 and occasional 3005, spoke with a rep this morning and followed all the steps like d1mebag and it hasn't helped whatsoever. This only started yesterday, previous to that it was fine.

Playing from Brisbane on the Aus servers with TPG.

Would love to hear something from a Blizz Rep about it...
My ISP is TPG as well, playing from Melbourne Victoria.
Im receiving multiple disconnections hourly (Error code 3005/3007) while being still connected to the internet.
Quite frustrating especially in public games where its impossible to rejoin.
I have been getting random, frequent 3005 and 3007 errors since last night. No other programs or websites are affected. Have tested this on 2 laptops and 2 desktops, using both wifi and ethernet connections.

My ISP is also TPG
Funny people are mentioning it. But I'm also a TPG customer.

Maybe there's something there.
Oh no im seeing a trend, im TPG from Brisbane, I called them and they said no D/c on their side but we have 3 account d/c in 1 hit all the time
TPG in Brissy as well.

tried all the stuff I have read (secondary account logon, ipconfig /releases, general chat, port forwarding etc etc.

I can have good sessions where it wont drop for hours then others where it will range from 10 mins to maybe 30/45 mins before I get a 3007 error.

No issues with no other game or internet issue.
Same thing here, frequently DC'd with 3007 error.
This is beyond frustration now!

3 16 ms 15 ms 13 ms []
4 25 ms 21 ms 23 ms []
5 33 ms 34 ms 27 ms []
6 30 ms 34 ms 32 ms []
7 29 ms 27 ms 30 ms []
8 34 ms * 31 ms []
9 29 ms 30 ms 33 ms []
10 33 ms 31 ms 29 ms []
11 25 ms 43 ms 29 ms []
12 26 ms 25 ms 25 ms
13 reports: Destination net unreachable.

Trace complete.
Same random, frequent 3005 or 3007 errors last for almost one week. My ISP is TPG too, but other internet connection works good. I don't know why...
Bnet says Login Queue
During periods of high login traffic, may put you in a login queue. These queues help our servers process login attempts more effectively than if players are repeatedly clicking or spamming the login button and hoping to get lucky.

The login queue will not save your place if you leave or if you are removed because you did not enter your information correctly. To avoid sitting through the queue more than once, be sure to:

Stay in the queue until it finishes. Do not leave or restart the client.
Enter your account name and password correctly.
Enter your authenticator code promptly and correctly.
Accept any Terms of Use or License agreements promptly.
For information on current server status, see our CS Twitter, Facebook, and Support forums.

but this is bollocks fix your sh!t
playing hardcore ... wtf is blizzard doing ... anyone dying because of disconnect should be revived by blizzard.

and the ceo should also personaly reimburse the person there money for the game.

betcha they fix it in minutes
same 3005 and 3007's here. Also tpg going through brisbane. recurring theme with tpg it seems. Anyone from other isp's having problems?
Hey there Legend,

Yup I am also having 3007 again, see above in the April post. I have put my path ping in another post in the Aus/NZ and no response by a blue. I also put in the Blizz tech support forum and still nothing.

I submitted a ticket and they replied with the generic response of check it out with your ISP.
Yeh I'm TPG as well in Brisbane, and really starting to wonder if it's TPG and not D3. Hate to say it but seriously thinking of switching to the dark side i.e. Telstra

Join the Conversation

Return to Forum