ps3 cant export save data

Console Discussion
I logged in to export my data for the release of uee and when I click export I get a message saying "Your save data is corrupt, and could not be read for exporting" not sure what's happening here but I can play my save with no problem what so ever this is the only problem I seem to be having.

Thanks for any help in advance.
Hacker?
So just because I'm having an issue means I'm a hacker?
In all fairness he did use a question mark.

It was my first thought as well since hacked gear was so common perhaps someone you played with gave you a bugged item. But all hacks aside, perhaps only one of your characters got corrupted somehow and you simply need to open up all of your toons individually to and re-save them and see if the issue still exists.

After that perhaps you can link your PSN account to your Blizz account and get some tech help that way.
That did it. Not sure what it was but it worked after going into all the characters and backing or.

Thanks
Fantastic! Glad to hear it!
Glad to know all is well! For reference, here’s our support article which highlights the character save transfer process for consoles.
Im having this exact same issue and I have gone into each one of my characters and it still is saying corrupt.. (no, not a hacker)
same here...:/
Hi here my story on exporting from PS3 -> PS4 succesfully after having the same issue...

1 - sold my ps3 and had only a copy of the game with me and borrowed a ps3 for one day!! to reupload
2 - Uploading my own savegame -> success
3 - Uploading my girlfriends savegame ->"Your save data is corrupt, and could not be read for exporting"

Here my conclusion after investigating (a lot!) and reading (many forums).

At the time I created the savegame of my girlfriend she had no PSN account. Now for the sake of exporting I created a psn/sen and a battlenet account.

Now loading her save into this PS3 I first received an error message saying something like "This savegame was created with a different account etc. and no trophies". (Here I already started that something is fishy). And also exporting resulted in a "Your save data is corrupt, and could not be read for exporting"

The reason why it cannot be uploaded is that this savegame has no AccountID (or Blank), therefore uploading is not working.

So to fix this I logged in with my girfriends PSN account and started a new game. Savegames created using an active PSN account do not have a Blank AccountID!

Exported this NEWsavegame to a USB Stick

Used Savegame editors to read the AccountID from this NEWsavegame and resigning it to the OLDsavegame (the one which was "corrupt")

Now after resigning I moved the RESIGNEDsavegame to the USB Stick, copied it to PS3 and tried exporting this RESIGNEDsavegame and it worked.

If you are going to try this then do not forget to always make a backup. I hope I could help!

For me it sound like a bug or Blizzard forgot that there are people playing it without PSN accounts... And definitely this is not userfriendly and not everyone can do this!

EDIT: oh btw... no hacks and only one character on that save.. that logging into the char did not work for me
Still having this issue! Any further, simpler fixes? Cheers.
@nubcuk, can you please specify what saveeditor you've used? if possible with link to download
I too am experiencing the same issue. "Your save data is corrupt, and could not be read for exporting" Please help thank you
I am having this exact problem with my copy on PS3, my brother cannot transfer his D3 characters into RoS.
Seems this falls into a grey area too. Sony rep says this is a blizzard issue and according to blizzard tech support, this a Sony issue. So I guess that means we start over which I refuse to do.
My main account, the one attached to a PSN account, transferred no issues. My wife's, who was on a non PSN account, will not. Basicly, any friends who played couch co-op, with you have to start over.
@Onorogin Thats what I am thinking, my characters that I started with my PSN account transfer over fine, but my brothers, whom are not attached to a PSN account do not transfer over. From the previous poster @nubcuk, they state you need to alter some sort of meta data tag in the save game file via some sort of editing software which is something I am willing to try to make this work, I wish there was another way to do it though.

If there are any other solutions please help :)
I want to know if I get to keep my old finished challenges from original D3 after transfering to D3 UEE. I have 2 of each class in lvl 60 transfered but can't seem to find any classchallenges completed.

Why is that? ?
same here. Recently bought RoS and all my challenges points was gone. My main problem is that I had 84% trophies completed and I needed my "Prepared for Battle" trophy(Equip all Inventory slots with items that have a minimum required level of 60 or higher.)

I got my latest lvl 60 item on my barbarian, but the trophy didnt unlock. It's kinda important to me, since im a trophy hunter :P

Anyone with same issue?

Join the Conversation

Return to Forum