Getting rid of stuttering issue

General Discussion
PC spec Intel Q8400, 4GB Ram, Asus ENGTX460.

I have been playing around with many many settings and different driver version for D3.

The following is the best for D3 gameplay on my PC.

290.53 Beta Driver without Physx Driver, without HD Audio Driver and without 3D Vision on Fullscreen mode with no vertical sync.

I also uninstalled Asus Gamer OSD.

If you are having stuttering issue, you may try the above settings. This is just my sharing for the community, hope it helps.
It seems that by default Triple Buffering is off in Nvidia Control Panel. Turn it on really helps alot and remember to set your Physx to your GPU instead of automatic

After turning on triple buffering it seems to be ok now. I am happy :)
The best setting found so far...

Enable Triple Buffering
Force VSync to on
D3 in game option enable Vsync as well
Uninstall 3D Vision

Almost no Stuttering and rubber banding. :)
Hope this helps :)
for me the stutter had to do with my windows audio quality being set to 24 bit 192000hz i had to lower it and it fixed it. i went all the way down to 16bit 48000hz but im sure i didnt have to go that low.
hmmm...probably I am using the on-board audio codec, so stuttering problem does not link to it :)

hopefully when the game goes official it will be more stable.
Yes agree with the loading assets part, but before I make the adjustment stated above, the game just freezes a few seconds from time to time especially during big fight...

anyway, i have been running smoothly with my modified nvidia control panel settings. I hope this is not a pc specific(my pc) issue but a game wide issue, as this will be easier to troubleshoot. :)

if it has to do with loading, glad I just installed an SSD
now I just need in the Beta..

Join the Conversation

Return to Forum