Long installation

Technical Support
have been stuck on, updating setup files (while trying to install the beta) for the last 10 hours?? why is this? any ideas?
My brothers much older computer, downloaded and was ready to install in less than 20mins but says his operating system is not supported (he has vista). He is using the same internet connection as me
what os are you using?
windows 7
haha cheers ill try thankyou
How do I uninstall? I don't think I have installed anything?
You need you update your windows......Go to windows update.....and UPDATE. :)

Worked for me anyways....
thanks for the ideas guys
you can try running the install file as admin. Just right click and hit "run as administrator"

that is assuming you haven't tried that. Windows firewall have been said to affect that as well.
Any time I've had this issue rebooting to Safe Mode w/ Networking has solved it for me (to do this, mash on the F8 key just before the Windows logo comes up on reboot) .

Start the update from Safe Mode w/ Networking, once it gets past Updating Setup Files, reboot back to normal and it should work to get the actual patch.
haha you let it go for 10 hours? damn... i would have stopped it after 10 mins and started it again lol
thank you all, (10 hours was me exaggerating) sorry it wasn't obvious haha
I only have 515 and 868? and 380 but with no application file
04/20/2012 12:51 AMPosted by mansfield
updating setup files

Getting stuck on this is an indicator that you need to close out of it, delete any files that it may have partially installed into program files, and do a complete reinstall.

It's an issue I had with the MoP beta, and my friend had with the D3 beta. Not sure what causes it.

Edit: Additionally, the bit about making sure you right click the installer and do "run as administrator" is HUGE. That usually resolves it, when done with a fresh install.
sorry this is a noob question but where would I find the partially installed files?
I know program files but, there is no diablo 3 beta folder, what would it be under?
Thanks for all the positive feedback and advice, unfortunately nothing has worked for me.

Join the Conversation

Return to Forum