Updating System Files.

Technical Support
Prev 1 12 13 14 21 Next
Still this issue even with MoP (which i'm not that concerned about at the moment) I have gone and looked at the secondary logon thing and I did change it to a different setting even though it wasn't on "Disabled" in the first place I think I set it to "automatic" instead of "manual"

Seems like a lot of people have this issue with no real cure.
I had it with the beta as well and just said screw it and just never played it. I really hope it is some kind of beta bug that will cause no harm and my game will somehow be pre-downloaded like I thought it was.
Omrakos I don't know what you did/changed for me... I feel like I have tried all these things before but it finally worked following your instructions for other people. I love you and I wish to bear your child.
I had this problem, what worked for me was, right click the exe, go to properties then go to compatibility and set it to windows service pack 3 , also run as administrator. hope that helps someone
Few things that worked here, after all the other info did not:

* Shut down completely the windows firewall.

* Uninstall MoP beta and D3 beta.

* Run World of Warcraft if you have it installed, while trying to start the d3 installer.

Worked here.
Is this even compatible with Windows 7 x64? I downloaded that file front folder all excited for my install to work, but I still got failed to run a required program AGENT

the .exe just plain wont run on my computer. I'm moments away from formatting and reinstalling windows 7 since no one else has my problem
Abe,

It's got to be a permissions issue then. Something's stopping files from being written to C:\Program\Battle.net.

Sometimes deleting the Cache folder in C:\ProgramData\Blizzard Entertainment\Battle.net can help so maybe try that next.

____________________________________________________________________
Support Information Administrator
i dont even have the programdata folder. what do i do?
Where is the program data folder?
05/14/2012 01:52 PMPosted by Xmorph
Where is the program data folder?


enable hidden files. then it's on the root of c
05/14/2012 01:56 PMPosted by Sathlin
Where is the program data folder?


enable hidden files. then it's on the root of c
how do i enable hidden?
I've uploaded my working Battle.net files to see if it may help anyone. Feel free to test and let me know.

http://www.gamefront.com/files/21699449/D3+-+Battle.net+Files.zip

Place them inside: C:\ProgramData\Battle.net

Agent
Client
Setup


Thanks a lot. This did help me get to the install screen. Now lets hope it works from here.
i had the issue where you hit play and it just sits there.
anways, thanks for the files.
05/14/2012 02:03 PMPosted by Xmorph


enable hidden files. then it's on the root of c
how do i enable hidden?


05/14/2012 02:03 PMPosted by Xmorph


enable hidden files. then it's on the root of c
how do i enable hidden?


open windows explorer. click tools, folder options, view, then select show hidden files.
what worked for me was right click the setup file>options> and run compatibility mode to windows xp service pack 3. Im on Windows 7 btw. and Woala it installed.

I've tried numerous methods posted on here and i hope this works for someone.
ok i enabled hidden and deleted my cashe but and it still is stuck on updating setup files
Hello friends,

after trying to fix this since BETA (for a month) and like 4 hrs today, I finally got fed up and just formatted/reinstalled windows 7 and immediately tried installing D3 on a fresh win install

The launcher installed fine, and the client is downloading now.

That's all I got =\
Omrakos I may give you a big sloppy kiss. Much love to you my man. Secondary logon was my issue.
in reference to the secondary logon issue. are you setting it to startup auto with windows?
they said as long as it is not disabled it should be fine. mine is set up to manual.
Ok this is what finally got me to the installer..

I went into the secondary logon properties, like was instructed earlier in the topic, and it was set to Manual. When I started the Setup, I got to 1/3 and it froze. In secondary logon properties the "Service Status" was Stopped. I hit the Start button and it jumped to 2/3 and froze again. I hit Stop and then Start and it jumped to 90%. I hit Stop then Start and it finished and I got to the installer.

No clue as to why I had to stop/start in Secondary Logon Properties to get the setup to move like that but it worked :/
Using legitpwnage's b.net files, do you just unpack them and run the D3 setup again? The install is sitting at 0% with no network activity going. I think I'm as screwed as I was 5 minutes ago.

Join the Conversation

Return to Forum