Failed to read a required file.

Technical Support
I have been trying multiple things to solve this, but the error I keep constantly getting is:

Failed to read a required file. Please close all other applications, temporarily deactivate your anti-virus software, and try again.

I did what this said, and even ran as administrator as well as turned off my firewall, I am still getting this error, some help would be greatly appreciated.
I have the same problem. I have it installed, and I can click "play". The launcher sits at "Initializing" for about 5 seconds before that error pops up and closes itself.

I found that if you press play before you allow the error to pop up, you can get to the log in screen, (But not actually play as the servers aren't up) but I would also like to know why this error pops up. Is it a big deal?
Ive been getting this same error all day. I deleted my pre-download (DOH!) thinking it was a bad install but now I can't even pre-download, it just gives me the Cant read msg!
me to, a ton of players have had this problem and i have not found a fix nor blizzard saying they need to fix anything. if you look around the forums we have 1000s of error threads and alot have been up since beta the problems were never solved and it in no way impacted blizzards sales of the game i think alot of ppl now have 60$ paper weights.
Same error here. Was downloading and installing, got greedy and stupid when I got in the yellow and hit play. Now i'm screwed with this. DAMNIT.
Open your task manager and if agent.exe is running hit end process. Or restart your computer.
i got the same error once or twice restarted my computer then started getting the other common error where people are getting stuck at initialization on the launcher, restarted my pc one more time and ran the launcher as Admin and go straight in. i now refuse to leave the login screen till i can play lol just going to stay alt tabbed.

Join the Conversation

Return to Forum