Still Cannot download the game

Technical Support
I've tried so many methods and asked for solutions but I'm still stuck with these errors.

1. Using the blizzard installer I get "The tracker is not responding." Before that it was the "the behind the firewall" error but I don't get that anymore. Tried opening all the ports for blizzard and disabling peer to peer which did not help.

2. I tried bluecows method of downloading all the parts of the game manually and when I clicked diablo 3 setup I get and error that say's I cannot run a required program (agent).

I'm completely stumped and out of ideas. Are they really gonna release the so-called web installer to download the game? (Where is the source for that?) or do I've power run to my grandma's house with my pc and attempt to download the game from there? Because those seem like my last two options. I already spent my months salary on d3 and cannot afford to purchase a retail copy.

C'mon blizzard wtf?
Finally got over the "the tracker is not responding error" after trying a million things out... Don't wanna jinx myself since it's still at 1% but I got it to move now. ^_^

Join the Conversation

Return to Forum