Failed to run required program (Agent)

Technical Support
1 2 3 15 Next
I couldn't find any posts with a similar issue so I created this. I understand that your unable to install, but I wanted to make sure the update thing worked at least.

When I run Diablo 3's setup after download it does the whole "Checking for updates" and it gets about halfway across when an error "Failed to run a required program (agent)" appears with the error code "BLZPTS00007"
Tausken,

Start with deleting the C:\ProgramData\Battle.net folder and restarting the installer. That will force it to reacquire the setup files which may be all it needs.

____________________________________________________________________
Support Information Administrator
Thanks Omrakos for the quick response.

I gave deleting the folder and restarting the installer a go, but I am still receiving the error message.
Do that ↑ first.

If that doesn't help, and during "Checking for updates" you see multiple Agent.exe processes appearing in the tasks list, it means work offline mode is enabled on Internet Explorer.
Thank you Barthus that worked.
Strangely enough, I've never seen anyone reporting this before and it's been quite some time since I ran the launcher with 'Work offline' mode enabled to see if the agent was able to take IE out of 'Work offline' mode or not.
Barthus,

I just tested it too and it doesn't. It just stays at the beginning of Updating Setup Files, and eventually multiple Agent.exes are started. You had it right on..

____________________________________________________________________
Support Information Administrator
I think the Setup starts the Agent, then tries to query it to see if it's running but gets no response. It then starts a new Agent process, the same happens, and it keeps trying for a while before returning the error.
same problem here delete the Battle.net folder like 20-30 times and try again dont work restart the pc not work.
disable fire wall not work.
disable antivirus not work.
have 1mb bandwith, on pandaren it work in like 7 days of trys.
Very bad installer and update i have see on all MMORPG and rol games
and the Agent installer comes from Blizzard? that right?
Tera, Lingae, rift, Aion perfect good installers
poor Blizzard
I'm having this same problem and I don't understand how to fix it still.

I don't have the c:programdata battlenet folder only a electronic arts folder from sims 3.
because I had to manually download all the parts and put them in a folder because the blizzard downloader wouldn't work for me.
Take your IE out of Work offline mode:
  • Open Internet Explorer, Press Alt + F and uncheck Work offline.


-
While at it (Still on IE), click on Tools > Internet options > Connections tab > and select Never dial a connection.

After changing that option to never dial a connection, click on LAN Settings and uncheck every single check box there.
i think its bs that i even have to do all this bull!@#$ to download this game......... %^-* downloader
I did everything and it didnt work till I did what Barthus posted above them me and a friend got right in. Thank you sure done raging after 3 days!!!!!!!!!!
I am having this problem, Internet Explorer and Firefox are not checked under work off-line...
I had this with the beta client, so I shrugged and figured it'd be fixed for launch

I digitally downloaded the game, deleted battle.net folder and all d3 related files 100 times rebooting, changing IE options, running as administrator, even reinstalled .net framework 4 and I still get failed to run a required program (Agent) every single time. I can't even dbl click agent.exe and I've never seen agent.exe running in my task manager while trying to endlessly install the client-installer.exe.

Guess i'm not allowed to play?

edit: if i buy the DVD game will it install or will I still get this ridiculous error and be unable to play?

edit2: I read somewhere that you can run agent.exe yourself before running the patcher, but for me (windows 7) I can't dbl click it, right click run as administrator, or do anything to get agent.exe running in my task manager. It's like agent doesn't exist and my computer doesn't feel like running it.
Tausken,

Start with deleting the C:\ProgramData\Battle.net folder and restarting the installer. That will force it to reacquire the setup files which may be all it needs.

____________________________________________________________________
Support Information Administrator


is there any final fix for that issue, i have tried everything this forum sugested
Yeah ive done everything this forum has suggested as well, and no avail.
I had this with the beta client, so I shrugged and figured it'd be fixed for launch

I digitally downloaded the game, deleted battle.net folder and all d3 related files 100 times rebooting, changing IE options, running as administrator, even reinstalled .net framework 4 and I still get failed to run a required program (Agent) every single time. I can't even dbl click agent.exe and I've never seen agent.exe running in my task manager while trying to endlessly install the client-installer.exe.

Guess i'm not allowed to play?

edit: if i buy the DVD game will it install or will I still get this ridiculous error and be unable to play?

edit2: I read somewhere that you can run agent.exe yourself before running the patcher, but for me (windows 7) I can't dbl click it, right click run as administrator, or do anything to get agent.exe running in my task manager. It's like agent doesn't exist and my computer doesn't feel like running it.


Same exact problem... Was same problem when I tried DLing MoP beta 2 months ago and just gave up. Now it's T-12 hours and it's still an issue... Ugh
Before you get the error, did you check if multiple Agent.exe processes were being started or you see no agent.exe processes at all?
Mine is running

Join the Conversation

Return to Forum