Unexpected decryption error

Technical Support
hi all, usually when i click install on the D3 installer it says something along the lines of "the star has yet to fall" or something....but now once i click AGREE it says "An unexpected decryption error occurred. Please contact customer support".....is this normal or is there something wrong with my installer?

thanks! :)
Same thing happens with my installer as well. I hope this error is due to the fact we can't dowaload the game till May 14.

I have no .part
I can lauch the setup

Here is the issue. (a weird one)
-When pressing on the install button theres almost 50% chance that its says the star has not fallen thing.Wich is normal but.
-Sometimes its bring me to the install directory, where i have to agree with the terms to install the game. I agree then its says : An unexpected decryption error occurred. Please contact Customer Support.''
05/13/2012 01:21 PMPosted by Erenash
.is this normal or is there something wrong with my installer?
Not normal.

05/13/2012 01:27 PMPosted by LiLxMelenor
I hope this error is due to the fact we can't dowaload the game till May 14.
Nope. Something is wrong with your installation files.

Open the Diablo folder and make sure none of your files have a .part extension. If so, start the downloader, point the download to the same location and let it finish the download. A lot of people close the downloader prematurely just because they see 100%, sometimes it takes a few minutes to complete.
ahhh....now i see what i did wrong, i tried to be smart and move my D3 setup installer to my desktop LOL, when i moved it back to where all the D3 installation files were it starts normally now with "the fire from the sky still falls"... LOL
thanks for responding guys :)
05/13/2012 01:32 PMPosted by Legitpwnage
Open the Diablo folder and make sure none of your files have a .part extension. If so, start the downloader, point the download to the same location and let it finish the download. A lot of people close the downloader prematurely just because they see 100%, sometimes it takes a few minutes to complete.


Done it 6 times at least. 2 times for every NEW location iv tryed.Guess ill try a 7th time.
05/13/2012 02:44 PMPosted by LiLxMelenor
Done it 6 times at least. 2 times for every NEW location iv tryed.Guess ill try a 7th time.
Try the steps I posted in this other thread: http://us.battle.net/d3/en/forum/topic/4927183412

Specifically showing your file extensions and deleting the battle.net folder.

Join the Conversation

Return to Forum