"Updating setup files..."

Technical Support
I ran Diablo III setup.exe from the 7.60gb file I downloaded days ago

AND

re-downloaded the 30mb setup just now off bnet

same result. what gives??
Mine's stuck here, too.
I also have the same problem. I've been looking in all of the troubleshooting on battle.net, but have had no luck
I found the solution here. The first one worked for me.

http://www.keenandgraev.com/2012/05/12/diablo-3-stuck-updating-setup-files-fix/
Thanks, the first solution worked for me as well.
Also having same problem; absolutely nothing works to fix it. Installer is just broken. I've even ran the dler again to check all the files and it says all are downloaded properly. I have a 15 gig a month cap and I can't download an entire 7 gig game again. Blizzard what's going on here????
You'd think Blizzard would pay attention to people that couldn't play they're amazing new game. And no none of the fixes worked for me either.
Nothing works for me either...Game preordered...
If the user has any connections configured in "Dial-up and Virtual Private Network settings" and they're set to "Dial whenever a network connection is not present," the install won't proceed past 10%.

Finally this worked for me
Stuck at 2/3s install, help
Seems they've taken our money and closed up shop. I have seen suggestions from users, but no official statements from Blizzard Entertainment. Either they are sitting on their asses waiting for someone else to do their job and find a work-around, or they simply don't care now that they have our money. I for one am hoping I can get my money back. I pre-ordered and I received a faulty product that does not work on hardware that is within their specified recommendations. We've been sold a lemon lads. Time to burn them at the stake.
On the link above, option #2 worked for me

Windows 7 Home Premiun, X64bit.

Asus G74SX.

Hope this somewhat provides information on what to build off of.

For those who don't feel like links, this is the option I tried:

Right click on the Diablo 3 setup file you downloaded via the Blizzard Downloader

Select Properties > Compatibility > Check Run this in Compatibility Mode for… > Choose Windows XP (Service Pack 3) (Note: Does not work on Vista.)

Right Click the Icon, Run as Administrator.

Join the Conversation

Return to Forum