ERROR: The file Installer Tome 2.MPQE could..

Technical Support
Prev 1 22 23 24 26 Next
I was getting error 108 so I followed everyones directions and repointed it at the directory with all my files.

Now I'm getting an error about my installation disc being ejected and that I should go download it digitally.

I guess I'm starting from scratch as well.
we could sue blizzard, get our money back :)
When I was pre-downloading the installer weeks ago, downloader was at 100% but I noticed my Installer Tome 3.MPQE has a '.part'.

I realized this would cause problem when the installer unlocks so I tried to find a way to download Installer Tome 3.MPQE wiithout using the downloader. I noted where the downloader was getting the files and got this, one of many:

Then I downloaded Intaller Tome 3.MPQE with Orbit download manager with this:

Downloads faster than the blizz downloader, works with all the files if you have other files with '.part', just follow the directory structure, replace spaces with %20.

I installed the game without problems.
Gah, now I have to wait an hour for it to download again. Glad they let us do this the day before, I would be PISSED if I ran into this problem when I could actually be playing the game.
Anyone tweak blizzard downloader ports recently?
I'm having the same problem too about the installation disc being and i should install it digitally.. what should i do??
mine stopped at 40% , try grabing the fresh d3 client off the website, it seems different from the one i downloaded before and it worked fine afterwards.
Had the Tome error also, Just keep trying and trying to open the install streamer thing, and BOOM so far so good Rolling @ 41% currently, where as before it would stop at 4% and error out,

I'm hoping this is me getting very lucky and manage to get everything installed and ready for opening!
At 56% . So far no errors ! yay
you will not be able to install till after 12:01 pst probably. ?
I must be lucky because I didn't get a single error.
Thanks this worked for me,

Hope it works for others as well
So I managed to fix it without redownloading more than 40 MB, this was my scenario and maybe it can help others.
I was getting an error for Tome 3, and I noticed Installer Tome 3.MPQE.part but not the desired Installer Tome 3.MPQE itself, the file was 3.57 GB, so it looked complete according to what others were reporting.

I tried rerunning the original installer, Diablo-III-8370-enUS-Installer-downloader, and it ran through the files, it created an Installer Tome 3.MPQE but of only 1 KB and it left the Installer Tome 3.MPQE.part. I tried this like 3 times, including running the installer as an admin.

What I ended up doing, and I'm not sure if it was what really fixed it, I deleted a couple of small files, in my case, SetupOSX.mpq and SetupWin.mpq, so this time the downloader took its time to redownload the missing files and it finally fixed Installer Tome 3.MPQE integrity. As others said, after a successful download, the installer started on its own and did a proper install.

So there it is, in case some people find this useful.


This worked for me and I didnt have to redownload the client! Thank you so much
05/14/2012 09:31 AMPosted by SagetPain

mines the same now as well. I was at 76% when i got an error for corrupted files or something then automatically closed out of the installer. Now im retrying at its just stuck at updating setup files...

This is an update to my post earlier (in case people are only reading the last few pages and are having a similar problem to mine). I copied and pasted my post from another thread:

Ok, this happened to me at around 76% (said corrupted file or something) and then the client automatically closed on me. After trying out a few different things that was posted in Bashiok's post (as mentioned above), this is what worked for me. I opened up the task manager and ended the agent.exe process and ran the diablo III setup as an administrator. After that the client was stuck at "updating setup files..." for about 10 minutes. I assumed i was still having problems but then I checked again and everything was finished. It said the game was up to date and I was ready to play (which I am now).

So I don't know what happened when the download stopped at 76% and I got that same error message (im almost thinking it was finished at that point anyways). So if you're stuck at "updating setup files..." then let it ride out for a little bit and it may just finish unexpectedly

Thanks so much, that was the error i had i did what you said and it worked and is fully installed.
I have a little development experience and the rule of thumb is to make things as dummy proof as possible. Disabling the cancel button and providing a label that said "working..." while the download was unpacking, would have alleviated this particular problem. If things can go wrong, they will.

I nearly clicked cancel myself after a several minutes of it reporting 100%. Luckily a little voice told me to be patient, so I stepped away from the keys to do something. When I returned, it was to an Install screen.

So yes, when hundreds of people are experiencing a problem that the developer could have spared them from, it most certainly is the developer's fault.
Lol must suck to not have the game downloaded yet. Keep on tryin

Join the Conversation

Return to Forum