Unexpected error

Technical Support
Tried to start Installing the game can accept the terms of service then on the next screen i receive the pop-up "an unexpected error has occurred"
should i re download?
I have the same thing happening to me.
Exact same thing here .. did the download weeks ago and now i just except the ULA and then unexpected error.
Try re-downloading to the same directory , it should verify your current installer - I did this (as recommended in another thread) and it worked for me, downloaded a few MB and installed fine after that.
Oh tuoweit if only you'd posted sooner. in my frustration i deleted the previously downloaded files. going to try downloading again. should only take 3 hours
redownload the game client from your account management page (it should takes a few secs), then initiate installing
it worked for me

it seems that old client from months ago does not work.
Re-downloading to the same directory helped me too, for some reason it wanted to download another 20 MB or so, installed sweet as after that, thanks guys!
I tried this, didn't work. Then redownloaded the downloader and downloaded to the same directory and it worked.

You need an updated downloader first, then download to the same directory. Will add 20mb or so and then you can install

Join the Conversation

Return to Forum