Video Card "unsupported" but not on list.

Technical Support
My video card is older, ATI Radeon HD 4800 Series, but worked fine during the Beta Test of Diablo 3.

After downloading and installing the game, I'm now getting a message that says it is unsupported. It does not appear on the list on the web page, or on the list posted in this forum.

Am I receiving this message in error, or is list on forum incomplete?
I have the same issue, it worked during the open beta after I've updated to Catalyst 12.3. I am using Radeon HD 4850. I haven't made any changes to my system so it should still work. Dunno what's wrong this time.
I'm having the same exact issue. Radeon HD 4800 on Vista SP2. This link lists it as supported high-performance.
I just checked with Catalyst and they've got an update to 12.4. I'm dl'ing now to see if it fixes the issue, but I've noticed a steady stream of Radeon HD users that are getting the same error, regardless of which card type they are using.
When it pops up that the card is unsupported just hit escape instead of clicking the ok button. It should bypass the error and take you to the game screen.

Edit: Make sure you download the Catalyst 12.4a hotfix if you are still having issues.
Thanks a ton Grisa! Working fine now!
just installed catalyst 12.4 + hotfix and it still shows the video not supported.

the esc key trick works. thanks Gisa
The escape key trick is working for nvidia cards as well, I'm having the same problem but with a geforce 8600 gt. Don't know why it's having any problems.
Yeah i have a Nvidia GeForce 9200 and i get that message, plays WoW fine but not D3, thats lame.
Oh great. Now I'm kinda regretting that annual pass. >_<

I have an ATI Radeon 4870 X2 running the very stable driver set of 10.9.

I can run WOW, Skyrim, SWTOR and just about every other new game out there....but hearing this I'm kinda worried that I'll be locked out of Diablo 3.

The esc key thing works! I wouldn't worry about being locked out, it seems like its just an issue with detecting a valid card that they'll probably fix. Hitting esc instead of ok lets you into the game (at least as far as you can go at the moment.)

Join the Conversation

Return to Forum