Press Play, Game does not launch

Technical Support
Prev 1 6 7 8 10 Next
Its odd that I can get into the game when I do a fresh installation, but if I try to reenter the game after existing I get the gray screen. Needing to wait ~30 min each time I want to log on isn't exactly a fair thing to ask of me lol. Let to expect my poor computer to rewrite all that content over and over...
Same problem.. Hit the "Play" button and it says "Launching" ,but it never does and never gives a error
ThankYou vl4d, your solution worked !!!

I went to the Diablo 3 folder in Program Files (Windows 7 32 bits), inside there are 2 executable files, Diablo III.exe and Diablo III Launcher.exe, I did a right click on Diablo III.exe and selected create shorcut, then on the shortcut I did a right click and selected properties, on the screen that pops up (shortcut tab) there is a field called Target that has the location of your Diablo III.exe , in my case it was "C:\Program Files\Diablo III\Diablo III.exe", so I added -launch at the end so it would look like this "C:\Program Files\Diablo III\Diablo III.exe" -launch, then click on Ok and thats it... well in my case I had to move this shorcut to my desktop for easy access (I created it inside Diablo III directory not in my desktop)

Having invested in a new video card + game for nothing... It's not funny.
There is another thread where this issue was talked about

What I discovered is when I closed or crashed Diablo 3, somehow my grahpic drivers and/or graphics card gets corrupted/unusable. My system hard reboots and I have to redownload the graphics driver. I'm on a laptop with an Nvidia GTX 560M, windows 7. The game runs in compatibility mode for me (not sure why) for windows XP SP3. Try reinstalling your graphics drivers and/or the other solutions listed in the other forum. Good Luck!
Blizzard please fix this!
First, sorry for my English :)

Same problem. (after hit play button, diablo3 banner shows up, than it's dissapears, nothing happens. After that nothing happens, but the agent.exe and diablo3.exe still there in the taskmanager)

It's happened with me in the open beta, and now in the real game too. I've tried all sulotions what i saw, but nothing happened. Today, I installed the game to my father's notebook, there it's works perfectly. But in mine does the same problem as everyones PC's or Notebooks.

A blue post would be great. (after 7 pages, we have the right to expect it so much) :(
I get the banner, and then the screen flashes black like it is going to open, and then nothing. It just closes and goes back to desktop.

Now, heres the interesting part. It worked last night. I didn't even turn of my computer when I went to bed. I just tried to log back on this morning/Afternoon and it didn't work.

Since then I have tried rebooting, and deleteing the folder, neither of those worked.

Maybe this solution helps. I've got Symantec virus scanner and it's alway blocks my svchost.exe (i dont know where can i change to apply it ).
I'm getting an error like this too. when I go to the D3 debug log, the only error I see is Direct3DCreate() created an unsuitable D3D (0, 1)

lots of times. Any idea what's wrong?
Same problem, it patches (every time) then when I click play it does nothing.

Is it posted anywhere that blizzard tech support has even acknowledged this problem?
Solution that worked for me Windows 7 64 bit ultimate edition:

I went to the install folder and right clicked and changed the property for the Diablo III.exe (not the Diablo III Launcher.exe ) under the compatibility tab; I checked the "Run this program as administrator".

After I did this, running the game through the launcher shortcut (created by installation) on the desktop worked like a charm.

Hopefully this works for you guys.
I found i fix to my issue!
This is what i done.
made sure Windows 7 Ultimate was up to date (including gtx550 ti update in the non critical updates was also updated)

went to
c:\programData\\agent\agent 868
ran the Agent.exe in that folder
a cmd screen opened and ran thru alot of text.

this then allowed me to set the D3 launcher and diablo3.exe as Run as Admin (in properties)
also set the Agent.exe in the Agent 954 folder to Run as Admin.

launched game

Still cant get it to launch, I click "PLAY", I get the D3 logo for a bit then it vanishes and nothing. Agent.exe*32 and Diablo III.exe*32 are still running in Processes.

Running it on an up to date Vista 64-bit system and all my drivers are up to date.
Did you end the Agent.exe and DiabloIII.exe processes?
then finds and run the Agent 868.exe and let it run all the way thru?
Cant find an Agent 858.exe
Same crap I hit play, and my screen blinks from black to the start up page, only way to stop it is to end process in task manager. Bought a radeon 6670 and memory card for it, Im not happy.
Seriously Blizzard you take a lot of money for this game and i believe you have enough employees to fix this solution or atleast one of them can tell those people something. There is 139 post here and not a single !@#$ was given. shame on you

Join the Conversation

Return to Forum