Launcher pops up, press PLAY is not launching

Technical Support
1 2 3 20 Next
So the launcher pops up, everything is downloaded to 100%, the PLAY button lights up green, I click it, it says launching...and just sits there. Nothing. I have been up for hours waiting for this like many others. Please help or direct to help for this. Thank you.
Same. updating files finishes, full green bar. Hit play button. It turns grey and I just have 'launching...' under the bar :-/
same.... sad in pants :(
My wife had this issue. After 5-10 minutes it actually launched, giving some sort of warning about her anti virus program.
same. win7 64bit, all antivirus etc turned off, running as admin. worked fine earlier today
Been having same problem for hour and half. Last night around 8PM EST I was able to launch game no problems, watch opening cinematic, set graphics options.

Now this.....
i have been stuck and also on the phone with people from support.... noone is able to solve whats going on. whaaaaaaaaaaat. SAME EXACT PROBLEM with the PLAY BUTTON
i feel like my computer is getting dirtier as we speak just by having all my anti-virus is down.... so dirty :(
i feel relieved not to be the only one :D! brothers and sisters in arms !!
05/15/2012 01:08 AMPosted by Sourlowsx
same. win7 64bit, all antivirus etc turned off, running as admin. worked fine earlier today

Any info on this?
your guess is as good as ours :<
ive tried rebooting several times, ending agent.exe and reopening the launcher as had worked for some people getting the 'failed to read required file' error. id rather just go to sleep but i made a very poor life decision and drank energy drinks earlier in anticipation of this game.
I wouldn't feel half as bad if I could even just get to the login page. At least I'd know my copy of D3 works. I can't believe I wasted my leave for this nonsense.
Try right clicking the shortcut for the launcher and selecting run as admin.
Already did that multiple times, tried the agent.exe thing as well, set p2penable to both true and false, turned off my anti-virus, whatever I could think of. Couple of my friends are already at lvl 5 and I still can't get this game to launch.
well i'm glad i made my vacay for July.... should work then i hope :D
it randomly worked. try restarting the launcher, blizz literally just changed something. youll notice the interface on the launcher has changed from what it was a few mins ago

ill move on to the other errors now, ty ;)
er i have the same problem. I could easily get on the login screen this morning but now i can't get past the launch screen. It says 100% but when i click the play button it goes grey.

Blizzard staff help pls!
Same problem..

I try reinstall 2 times and nothing... =/

Join the Conversation

Return to Forum