D3 is using my intergrated graphics card!

Technical Support
It seems that Diablo 3 is using my integrated GPU over my GT 540M, is there a way to make Diablo 3 use my GT 540m? Or any advice would be helpful thanks!
bump i want to know too
You'll need to go into your video card's control panel and force it to use the dedicated GPU. Currently neither AMD or nVidia are detecting Diablo 3 correctly, so it won't do it automatically.
Thanks. Should that be in the control panel under manage devices that I access that?
I believe I got it, I went into my Nvidia control panel. Selected Diablo 3 and changed it from automatic gpu to my 540m! Hope it works
And how did that work for you? I have the same issue. My laptop has 2 graphic cards and D3 works equaly slow on both (geforce 310M and integrated Intel something)
Have exactly that problem with exactly the same card. It doesn't matter what I do, it will only use integrated. I set diablo3.exe and diablo3launcher.exe to use the dedicated card (the 540M) and it switches to integrated the second the game starts (after I hit "Play' on the launcher, it will use the 540M for the launcher). I can right click and select to use the dedicated graphics card to run either executable and the same thing happens. Set the computer to always use dedicated, and it still switches to integrated. I've upgraded to the latest nVidia drivers and that did not fix the problem.
Hi Guys, im currently running a dell xps 17 and was having no problems until the other day when my fps went from ~40 FPS to ~20 FPS. Big drop if you ask me and almost unplayable with hordes of 20 or more. I was playing around with some options and went into my power options and changed it from "Balanced" to "High Performance" and then turned the "Shadow Quality" option to low and automatically saw my fps go back to a constant 50. Hope this helps in anyway.
06/15/2012 07:14 PMPosted by VIROB
I was playing around with some options and went into my power options and changed it from "Balanced" to "High Performance" and then turned the "Shadow Quality" option to low and automatically saw my fps go back to a constant 50. Hope this helps in anyway.

I've tried this. Nothing. Has anyone else had success in fixing this? I'm in pretty much the same boat. I have a K73S Asus laptop, Geforce GT 540M, i5 2430M, 4gigs. When I run the game, it is choppy. Every 2-10 seconds it skips frames noticeably. That, combined with the rubber-banding still on Blizzard's end, makes game-play very unsatisfying.

I've tried what others here have tried, including "right click> run with graphics processor" and choosing the 540M. I can tell no performance difference when I run the 540M, or run it as integrated graphics. Either way, very choppy game-play. I suspect it is not running the 540M card at all.
Does this happen only when plugged in, only on battery or both? It might be the dreaded Nvidia Optimus- GPU switching problem.
You need to go into your bios, and turn off your on-board video card. On my computer to enter the bios menu, I need to hit the Delete key, but it's not the same across all platforms. So look at the screen when you reboot to see if you lists a bios key option. If not then you can randomly try keys, or look up your board on the internet, to see which key is required to enter your bios. If you have a video card installed into a socket then you should already have disabled this function in your bios.

Ran into this problem recently. Re-installing my graphics driver did the trick for me.
I have a GeForce GTX765M and in the management panel, the selection between integrated and dedicated graphic card for the Diablo3 application is greyed out. I can't even change it.After reinstalling driver, Diablo3 used the right graphic card again
I have the same problem as Sakuya. Lenovo z710 Intel Graphics HD 4600 and Nvidia GeForce 745M. After stripping both Intel and Nvidia drivers out and reinstalling, I got it to work. But when I exited Diablo 3 and logged back in, the problem presented itself again. I thought it was a driver update from Intel that was causing the problem, but it isn't. LoL switches fine, Borderlands 2 switches fine. Tortchlight 2 switches fine. Eve-online switches fine. I can't even force Diablo 3 to use the card as the option is grayed out, it's basically saying "ha ha, go f**k yourself."
Ummmm my d3 was perfectly fine until today.... I boot it up and its running slow as !@#$. I suspected it was running off my integrated card, and granted I check my nvidia panel the box to choose my nvodia card gtx760 is greyed out with my integrated card... What gives??? Can someone help me out?
I was play Diablo 3 yesterday and it runs normaly (areound 30 fps NVIDIA graphics ) but today ill run aplication ( game ) and notebook dont switch the interged card into a NVIDIA ( other games like borderland 2 world of tanks etc do it fine ) but diablo after this patch no any option hot ho fix it? or blizz fixpatch? thx for reply
There used to be an option in the computer bios to disable the onboard sound card and or graphic card is you had purchased a seperate sound card or graphic card. Obviously this is more relevant to Desktop computers where hardware upgrades are not an issue. I have a Desktop PC with an onboard sound card which is disabled in bios as I use a seperate sound card. Windows only sees the seperate sound card. I do not know whether there is a option or options in the bios on laptops to disable the integrated card and allowing the dedicated card to be the only card seen by Windows on boot.

Worth checking?

Edited: Update:

Use AMD hardware so not an Intel expert.

Bios: All are different so you will need to navigate the various options.
The wording may not be exact with regard to your bios.

Look for Southbridge: Primary Adapter? may be under Advanced?

Look for igp > pci> pcie or something similar
(graphic adaptor to boot in Windows is the integrated card) - igp

Change the option to pcie> pci> igp
(graphic adaptor to boot in Windows is the dedicated card) - pcie

Save and exit the bios, reboot to Windows.

There should not be a need to enter the Nvidia control panel as the dedicated card should be running.
I have same problem with my Lenovo y570 with GeForce 555M
Just found this thread and am having the same problem. Until either yesterday or the day before, I had no problems forcing Diablo to run with my NVIDIA card, but all of the sudden, the option is now grayed out in the control panel. Every other program allows me to manually force the better card, but its clear its running off my integrated card right now.


Never mind, see: http://us.battle.net/d3/en/forum/topic/11913302274?page=8#143

Join the Conversation

Return to Forum