Updating Setup Files issues

Technical Support
So I was going to load up my D3, just to make sure it was working... well, it's not.
Ever since I started downloading the MoP Beta, and then the D3 Beta, I've been having issues.

Back when the digital download became available through the Annual Pass, I downloaded D3.. Got it through the download process (which was exceptionally slow) and go it to where it says "Fire still falls from the sky..." etc. So it downloaded without error.

Then I downloaded MoP Beta, then D3 Beta, and those started having fatal errors, and got stuck at "Updating Setup Files' I had to do a lot of jockying with the different solutions to get those to download. Now that they are downloaded I haven't thought much about it.

Until tonight. I tried to load up D3 knowing that in two hours time it goes live, and I thought well... hey.. Let's check just to be SURE. Yeah.. Stuck at "Updating Setup Files" about 60%. I tried deleting the battle.net folder, tried deleting the cache in the Blizzard Entertainment Folder. Tried changing the agent folder to agent.temp, tried deleting just the agent folder. Just the agent.524 and the agent.954 folders.. and all to no avail. I can NOT get passed this all of a sudden. Tried running in admin mode, in compatibility mode.. toggling these options.. as well as LAN settings, and everything else.

So any help or suggestions would be greatly appreciated.

Join the Conversation

Return to Forum