Downloader/ prelauncher keeps dissapearing...

Technical Support
Wow I can finally post on the forums, real glad it was limited to freaking WoW and starcraft players before the official release.

Anyway everything is fine and dandy with the pre launcher at first glance, until I leave it open for more than 60 seconds, after running and downloading normally it will just dissapear, the process will go bye-bye, no message, no sounds nothing, just dissapears as if I alt f4'd it. It has lasted varying times from a minute to 30 minutes but not longer yet, my d/l speed is not especially fast, so I would have to sit here for a lot of hours reopening it that I don't have, so far I've only gotten 1.3gb by sitting herea watch and reopening it like 200 times over the course of a couple of hours.

I've tried running it as admin, changing compat mode, restarting multiple times (pc and router), AV and firewall off, different regions client etc
I've also tried closing everything except the downloader, this seems to make it last a bit longer on average, but it still dissapears....
I'm having the same problem. However, I am noticing an error log every time it disappears.

This application has encountered a critical error:

ERROR #1 (0x13370001) Fatal Exception
Program: C:\Users\Stealth0ps\Desktop\Diablo-III-8370-enUS-Installer-downloader.exe
Exception: 0xC0000005 (ACCESS_VIOLATION) at 0023:0049F81E

The instruction at "0x0049F81E" referenced memory at "0x736149B8".
The memory could not be read.

Crashed Thread: 0x000011ec

Project: 19030001
Build: 1668
Project Name: Blizzard Downloader

Now I really don't know what all this means but maybe someone will see something and point it out to us.
I've just tried the WCIII downloader and it's definitely not dissapearing, so it's something just with the D3 version of the downloader. Also it only dissapears after it's done checking and is downloading, it does not dissapear before ever.

Join the Conversation

Return to Forum