cant install

Technical Support
tells me dosent suport my windows
check the tech forum, you still have 1hr 30 mins to figure it out.

i'll toss you a hint: go up to the compatibility issue, switch it to windows xp service 3 and admin. run it. then you may have to fiddle around with a few other things.
this is just stupid y is it bing so picky i mean i alredy have wow on this computer
ok this is just pissing me off
windows 95 not supported?!?! WTF
Have you tried installing it from the downloader or is that from the disc. If you did one, try the other and see if it works.
iv got xp and it says it suports it so this is bull!@#$
upgrade your XP to service pack 3 and you should be fine ....relax
if you don't know how to just simply goggle it :)
i cant get it to update to sp3 every time i try the website tells me an unexpected eror cant open web page
This is a FAQ for D3 Beta players that can´t install final version.
I had just buyed D3 for 48hours ago and download the normal client when I try all this:
I thought I missed some files and download the new client from here: And it didnt worked.
Then I update my windows and drivers and Net.Framework 4.
And it still not worked.
All before this I had uinstalled Beta diablo, but!! Under : C:\ProgramData there is a folder called battelnet. There is old agent.exe from blizzard used under beta it maybe !@#$ed it up. C:\ProgramData is a hiden folder on some OS. I delete C:\ProgramData\battelnet the folder battelnet. And tried again and it didn’t worked. Then I went on forum no answers could help. I download the files again from blizzard by this client Diablo-III-8370-enGB-Installer-downloader from And It worked. Oke
But maybe it not work for some people. So to be sure:
Update your windows, delete all! Files of beta also hiden temp files. Update driver to make sure and Net.Framework 4. And again update after install Net.Framework 4, windows have some after updater to that too.
When you had done that and redownload it can hang on 99% under the downloader. Close it and click on download run it as admin and it ask where to save the downloaded files. And you add it the predownloaded files are. When you can see the download is on 100% and still hanging and it not starting the client. Kill it on processerline. By Ctrl + alt + delete and you know it. You run the client as admin and it will start to decrypt the download files and it should work. Give it some time.
Then if it doing or it saying “Updating setup files….” Then it change to launching Blizzard Launcher” and back to “Updating setup files….” And it keep doing that in long time. Shot it down go to the Folder where you can see the downloaded file and client! Right click on the client! And go to properties and set it to XP service pack 3 and then right click on and run as admin! Bam it worked I can install what a hell of time and hard by me and not blizzard. Guys try this gl and hf. This is only one of the issue not them all! People say it take 14gb but mine says 15.1gb.! ;)

Join the Conversation

Return to Forum